SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Game)  >   Scorched 3D Vendors:   scorched3d.sourceforge.net
(Gentoo Issues Fix) Scorched 3D Format String Flaw Lets Remote Users Crash the Server and May Permit Arbitrary Code Execution
SecurityTracker Alert ID:  1009729
SecurityTracker URL:  http://securitytracker.com/id/1009729
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Apr 10 2004
Impact:   Denial of service via network, Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 36.2 and prior versions
Description:   A format string vulnerability was reported in Scorched 3D. A remote user can cause the game service to crash.

FieldySnuts reported that a remote user can open a chat window and type format string characters (such as '%n%n%n') to cause the game server to crash. It may also be possible to execute arbitrary code.

Gentoo also reported that there are some other buffer overflows in the code.

Impact:   A remote user can cause the game service to crash and may be able to execute arbitrary code on the target system with the privileges of the game server daemon.
Solution:   Gentoo has released a fix and indicates that Scorched 3D users should upgrade to version 37 or later:

# emerge sync

# emerge -pv ">=games-strategy/scorched3d-37"
# emerge ">=games-strategy/scorched3d-37"

Vendor URL:  scorched3d.sourceforge.net/ (Links to External Site)
Cause:   Boundary error, Input validation error, State error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Apr 10 2004 Scorched 3D Format String Flaw Lets Remote Users Crash the Server and May Permit Arbitrary Code Execution



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200404-12 ] Scorched 3D server chat box format string vulnerability



--yZxAaITavNk3ADw/
Content-Type: text/plain; charset=iso-8859-1
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200404-12
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                             http://security.gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: Scorched 3D server chat box format string vulnerability

      Date: April 09, 2004
      Bugs: #39302
        ID: 200404-12

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Scorched 3D is vulnerable to a format string attack in the chat box
that leads to Denial of Service on the game server and possibly allows
execution of arbitrary code.

Background
==========

Scorched 3D is a game based loosely on the classic DOS game "Scorched
Earth". Scorched 3D adds amongst other new features a 3D island
environment and LAN and internet play. Scorched 3D is totally free and
is available for multiple operating systems.

Affected packages
=================

    -------------------------------------------------------------------
     Package                    /   Vulnerable   /          Unaffected
    -------------------------------------------------------------------
     games-strategy/scorched3d         < 37                      >= 37

Description
===========

Scorched 3D (build 36.2 and before) does not properly check the text
entered in the Chat box (T key). Using format string characters, you
can generate a heap overflow. This and several other unchecked buffers
have been corrected in the build 37 release.

Impact
======

This vulnerability can be easily exploited to remotely crash the
Scorched 3D server, disconnecting all clients. It could also
theorically be used to execute arbitrary code on the server with the
rights of the user running the server.

Workaround
==========

A workaround is not currently known for this issue. All users are
advised to upgrade to the latest version of the affected package.

Resolution
==========

Scorched 3D users should upgrade to version 37 or later:

    # emerge sync

    # emerge -pv ">=games-strategy/scorched3d-37"
    # emerge ">=games-strategy/scorched3d-37"

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

     http://security.gentoo.org/glsa/glsa-200404-12.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Technologies, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0

--yZxAaITavNk3ADw/
Content-Type: application/pgp-signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3 (GNU/Linux)

iD8DBQFAdqXoJPpRNiftIEYRAmTPAJ4lIPaqf8OrzRwkrDZBdo8eSJ+udgCdHuyP
PrpDKnojESxScEOKi0aZX1k=
=W88g
-----END PGP SIGNATURE-----

--yZxAaITavNk3ADw/--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC