SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Game)  >   Scorched 3D Vendors:   scorched3d.sourceforge.net
Scorched 3D Format String Flaw Lets Remote Users Crash the Server and May Permit Arbitrary Code Execution
SecurityTracker Alert ID:  1009728
SecurityTracker URL:  http://securitytracker.com/id/1009728
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Apr 10 2004
Impact:   Denial of service via network, Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): 36.2 and prior versions
Description:   A format string vulnerability was reported in Scorched 3D. A remote user can cause the game service to crash.

FieldySnuts reported that a remote user can open a chat window and type format string characters (such as '%n%n%n') to cause the game server to crash. It may also be possible to execute arbitrary code.

Gentoo also reported that there are some other buffer overflows in the code.

Impact:   A remote user can cause the game service to crash and may be able to execute arbitrary code on the target system with the privileges of the game server daemon.
Solution:   The vendor has issued a fixed version (37), available at:

http://scorched3d.sourceforge.net/downloads.php

Vendor URL:  scorched3d.sourceforge.net/ (Links to External Site)
Cause:   Boundary error, Input validation error, State error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Apr 10 2004 (Gentoo Issues Fix) Scorched 3D Format String Flaw Lets Remote Users Crash the Server and May Permit Arbitrary Code Execution
Gentoo has released a fix.



 Source Message Contents

Subject:  http://bugs.gentoo.org/show_bug.cgi?id=39302


http://bugs.gentoo.org/show_bug.cgi?id=39302

FieldySnuts reported a vulnerability in Scorched 3D.  A remote user can reportedly open a 
chat window and type format string characters (such as '%n%n%n') to cause the game server 
to crash and potentially execute arbitrary code.

Gentoo also reported that there are some other buffer overflows in the code.

The vendor has issued a fixed version (build 37), available at:

http://scorched3d.sourceforge.net/downloads.php

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC