SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Util-linux Vendors:   [Multiple Authors/Vendors]
(Gentoo Issues Fix) util-linux Login Program May Leak Authentication Data to Local Users
SecurityTracker Alert ID:  1009704
SecurityTracker URL:  http://securitytracker.com/id/1009704
CVE Reference:   CVE-2004-0080   (Links to External Site)
Date:  Apr 7 2004
Impact:   Disclosure of authentication information, Disclosure of system information, Disclosure of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   A vulnerability was reported in 'util-linux' in the login program. A local user may be able to view leaked data, including authentication data.

Red Hat reported that there is a vulnerability in 'util-linux' in the login program, at least as distributed with Red Hat Enterprise Linux 2.1AS.

The report indicates that, in some situations, that application may use a pointer that had been previously freed and subsequently reallocated. As a result, some data leakage may occur. For example, passwords may be written to wtmp.

Red Hat reports that Red Hat Enterprise Linux 3 and Red Hat Linux 9 are not affected.

[Editor's note: It is not clear whether other vendor distrubtions are affected or not.]

Impact:   A local user may be able to view leaked data, including authentication data.
Solution:   Gentoo has released a fix and indicates that all util-linux users should upgrade to version 2.12 or later:

# emerge sync

# emerge -pv ">=sys-apps/util-linux-2.12"
# emerge ">=sys-apps/util-linux-2.12"

Vendor URL:  freshmeat.net/projects/util-linux/ (Links to External Site)
Cause:   Access control error, State error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Feb 3 2004 util-linux Login Program May Leak Authentication Data to Local Users



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200404-06 ] Util-linux login may leak sensitive data



--7uYPyRQQ5N0D02nI
Content-Type: text/plain; charset=iso-8859-1
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200404-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                             http://security.gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Low
     Title: Util-linux login may leak sensitive data

      Date: April 07, 2004=20
      Bugs: #46422
        ID: 200404-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=3D=3D=3D=3D=3D=3D=3D=3D

The login program included in util-linux could leak sensitive
information under certain conditions.

Background
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

Util-linux is a suite of essential system utilites, including login,
agetty, fdisk.

Affected packages
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

    -------------------------------------------------------------------
     Package              /   Vulnerable   /                Unaffected
    -------------------------------------------------------------------
     sys-apps/util-linux        <=3D 2.11                        >=3D 2.12

Description
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

In some situations the login program could leak sensitive data due to
an incorrect usage of a reallocated pointer.

NOTE: Only users who have PAM support disabled on their	systems (i.e. -PAM =
in
their USE variable) will be affected by this vulnerability. By default, this
USE flag is enabled on all architectures. Users with PAM support on their
system receive login binaries as part of the pam-login package, which remai=
ns
unaffected.=09

Impact
=3D=3D=3D=3D=3D=3D

A remote attacker may obtain sensitive data.

Workaround
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

A workaround is not currently known for this issue. All users are advised to
upgrade to the latest version of the affected package.=09

Resolution
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

All util-linux users should upgrade to version 2.12 or later:

    # emerge sync

    # emerge -pv ">=3Dsys-apps/util-linux-2.12"
    # emerge ">=3Dsys-apps/util-linux-2.12"

References
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

  [ 1 ] http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCAN-2004-0080

Concerns?
=3D=3D=3D=3D=3D=3D=3D=3D=3D

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

--7uYPyRQQ5N0D02nI
Content-Type: application/pgp-signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3 (GNU/Linux)

iD8DBQFAdDszJPpRNiftIEYRAl1sAJ9Kcr7JbStQeSSGzti+VjdP8SbuwgCglS/I
1tIGdXXkuo8ow29hJg6HiNo=
=dKSO
-----END PGP SIGNATURE-----

--7uYPyRQQ5N0D02nI--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC