SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (E-mail Server)  >   Courier Mail Server Vendors:   Double Precision, Inc.
(Gentoo Issues Fix) Courier Mail Server 'iso2022jp' and 'shiftjis' Buffer Overflows May Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1009583
SecurityTracker URL:  http://securitytracker.com/id/1009583
CVE Reference:   CVE-2004-0224   (Links to External Site)
Date:  Mar 29 2004
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 3.0.0
Description:   Some buffer overflow vulnerabilities were reported in the Courier Mail Server. A remote user may be able to execute arbitrary code on the target system.

It is reported that there are buffer overflows in the 'iso2022jp.c' and 'shiftjis.c' files in the processing of unicode characters. A remote user can reportedly send specially crafted unicode text with characters that are outside of the Basic Multilingual Plane (BMP) range to trigger the overflow and potentially execute arbitrary code.

Impact:   A remote user may be able to execute arbitrary code on the target system.
Solution:   Gentoo has released a fix and recommends that all users upgrade to the current version of the affected packages:

# emerge sync

# emerge -pv ">=net-mail/courier-imap-3.0.0"
# emerge ">=net-mail/courier-imap-3.0.0"

# ** Or; depending on your installation... **

# emerge -pv ">=net-mail/courier-0.45"
# emerge ">=net-mail/courier-0.45"

Vendor URL:  www.courier-mta.org/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Mar 17 2004 Courier Mail Server 'iso2022jp' and 'shiftjis' Buffer Overflows May Let Remote Users Execute Arbitrary Code



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200403-06 ] Multiple remote buffer overflow vulnerabilities in Courier



--NYEXl3WhqsXurSTm
Content-Type: text/plain; charset=iso-8859-1
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200403-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                             http://security.gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Multiple remote buffer overflow vulnerabilities in Courier
      Date: March 26, 2004
      Bugs: #45584
        ID: 200403-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Remote buffer overflow vulnerabilites have been found in Courier-IMAP
and Courier MTA. These exploits may allow the execution of abritrary
code, allowing unauthorized access to a vulnerable system.

Background
==========

Courier MTA is a multiprotocol mail server suite that provides webmail,
mailing lists, IMAP, and POP3 services. Courier-IMAP is a standalone
server that gives IMAP access to local mailboxes.

Affected packages
=================

    -------------------------------------------------------------------
     Package                /   Vulnerable   /              Unaffected
    -------------------------------------------------------------------
     net-mail/courier-imap        < 3.0.0                     >= 3.0.0
     net-mail/courier             < 0.45                       >= 0.45

Description
===========

The vulnerabilities have been found in the 'SHIFT_JIS' converter in
'shiftjis.c' and 'ISO2022JP' converter in 'so2022jp.c'. An attacker may
supply Unicode characters that exceed BMP (Basic Multilingual Plane)
range, causing an overflow.

Impact
======

An attacker without privileges may exploit this vulnerability remotely,
allowing arbitrary code to be executed in order to gain unauthorized
access.

Workaround
==========

While a workaround is not currently known for this issue, all users are
advised to upgrade to the latest version of the affected packages.

Resolution
==========

All users should upgrade to the current version of the affected
packages:

    # emerge sync

    # emerge -pv ">=net-mail/courier-imap-3.0.0"
    # emerge ">=net-mail/courier-imap-3.0.0"

    # ** Or; depending on your installation... **

    # emerge -pv ">=net-mail/courier-0.45"
    # emerge ">=net-mail/courier-0.45"

References
==========

  [ 1 ] http://www.securityfocus.com/bid/9845
  [ 2 ] http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0224

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.


--NYEXl3WhqsXurSTm
Content-Type: application/pgp-signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3 (GNU/Linux)

iD8DBQFAZ9rZJPpRNiftIEYRAjoAAJsFag8I1YmG0+/7HbEuDcgEl28TlQCeKuDR
ukXm5/w5bwrZGxRDjKcJM/4=
=6B88
-----END PGP SIGNATURE-----

--NYEXl3WhqsXurSTm--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC