SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Security)  >   OpenSSL Vendors:   OpenSSL.org
(Gentoo Issues Fix) OpenSSL SSL/TLS Handshade Flaws May Let Remote Users Crash OpenSSL-based Applications
SecurityTracker Alert ID:  1009476
SecurityTracker URL:  http://securitytracker.com/id/1009476
CVE Reference:   CVE-2004-0079, CVE-2004-0081, CVE-2004-0112   (Links to External Site)
Date:  Mar 18 2004
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 0.9.6c - 0.9.6k and 0.9.7a - 0.9.7c
Description:   Some vulnerabilities were reported in OpenSSL, primarily involving the processing of SSL/TLS protocol handshakes. A remote user can cause OpenSSL to crash.

It is reported that there is a null-pointer assignment in the do_change_cipher_spec() function [CVE: CVE-2004-0079]. A remote user can perform a specially crafted SSL/TLS handshake with a target server to cause OpenSSL to crash on the target system. This may cause the application using OpenSSL to crash.

All versions of OpenSSL from 0.9.6c to 0.9.6k inclusive and from 0.9.7a to 0.9.7c inclusive are reportedly vulnerable to this null-pointer bug.

It is also reported that there is a flaw in performing SSL/TLS handshakes using Kerberos ciphersuites [CVE: CVE-2004-0112]. A remote user can perform a specially crafted SSL/TLS handshake against a server that is using Kerberos ciphersuites to cause OpenSSL to crash on the target system.

OpenSSL versions 0.9.7a, 0.9.7b, and 0.9.7c are reported to be vulnerable to this Kerberos handshake bug.

It is also reported that a remote user may be able to cause OpenSSL to enter an infinite loop due to a flaw in a patch introduced in 0.9.6d [CVE: CVE-2004-0081].

The vendor credits Dr. Stephen Henson of the OpenSSL core team as well as Codenomicon for supplying their TLS Test Tool and Joe Orton of Red Hat for performing the majority of the testing.

Impact:   A remote user can cause OpenSSL to crash, which may cause an application using OpenSSL to crash. The specific impact depends on the application that uses the OpenSSL library.
Solution:   Gentoo has released a fix and recommends that all users upgrade openssl to either 0.9.7d or 0.9.6m:

# emerge sync
# emerge -pv ">=dev-libs/openssl-0.9.7d"
# emerge ">=dev-libs/openssl-0.9.7d"

Vendor URL:  www.openssl.org/news/secadv_20040317.txt (Links to External Site)
Cause:   Boundary error, Exception handling error, State error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Mar 17 2004 OpenSSL SSL/TLS Handshade Flaws May Let Remote Users Crash OpenSSL-based Applications



 Source Message Contents

Subject:  [gentoo-announce] Gentoo Linux Security Advisory 200403-03: Multiple OpenSSL Vulnerabilities


This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enigF91E26DB7422153D1F8B422B
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200403-03
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                              http://security.gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

   Severity: Normal
      Title: Multiple OpenSSL Vulnerabilities
       Date: March 17, 2004
       Bugs: #44941
         ID: 200403-03

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Three vulnerabilities have been found in OpenSSL via a commercial test
suite for the TLS protocol developed by Codenomicon Ltd.

Background
==========

The OpenSSL Project is a collaborative effort to develop a robust,
commercial-grade, full-featured, and Open Source toolkit implementing
the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
v1) protocols as well as a full-strength general purpose cryptography
library.

Affected packages
=================

     -------------------------------------------------------------------
      Package           /   Vulnerable   /                   Unaffected
     -------------------------------------------------------------------
      dev-libs/openssl       <= 0.9.7c                        >= 0.9.7d
      dev-libs/openssl       <= 0.9.7c                        == 0.9.6m

Description
===========

1. Testing performed by the OpenSSL group using the Codenomicon TLS
    Test Tool uncovered a null-pointer assignment in the
    do_change_cipher_spec() function. A remote attacker could perform a
    carefully crafted SSL/TLS handshake against a server that used the
    OpenSSL library in such a way as to cause OpenSSL to crash.
    Depending on the application this could lead to a denial of service.
    All versions of OpenSSL from 0.9.6c to 0.9.6l inclusive and from
    0.9.7a to 0.9.7c inclusive are affected by this issue.

2. A flaw has been discovered in SSL/TLS handshaking code when using
    Kerberos ciphersuites. A remote attacker could perform a carefully
    crafted SSL/TLS handshake against a server configured to use
    Kerberos ciphersuites in such a way as to cause OpenSSL to crash.
    Most applications have no ability to use Kerberos cipher suites and
    will therefore be unaffected. Versions 0.9.7a, 0.9.7b, and 0.9.7c of
    OpenSSL are affected by this issue.

3. Testing performed by the OpenSSL group using the Codenomicon TLS
    Test Tool uncovered a bug in older versions of OpenSSL 0.9.6 that
    can lead to a Denial of Service attack (infinite loop). This issue
    was traced to a fix that was added to OpenSSL 0.9.6d some time ago.
    This issue will affect vendors that ship older versions of OpenSSL
    with backported security patches.

Impact
======

Although there are no public exploits known for bug, users are
recommended to upgrade to ensure the security of their infrastructure.

Workaround
==========

There is no immediate workaround; a software upgrade is required. The
vulnerable function in the code has been rewritten.

Resolution
==========

All users are recommened to upgrade openssl to either 0.9.7d or 0.9.6m:

     # emerge sync
     # emerge -pv ">=dev-libs/openssl-0.9.7d"
     # emerge ">=dev-libs/openssl-0.9.7d"

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

--------------enigF91E26DB7422153D1F8B422B
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFAWFRkGf+dpzdp08kRAhZUAJ9hjwvLK+Ujb2mjKphhpO11ZREHNgCdFNIU
/KDd7ic0PKo/ONXuoiYlP2Y=
=oYkr
-----END PGP SIGNATURE-----

--------------enigF91E26DB7422153D1F8B422B--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC