SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Forum/Board/Portal)  >   YaBB SE Vendors:   YaBBSE.org
YaBB SE Input Validation Flaws in 'glow' and 'shadow' Tags Permit Cross-Site Scripting Attacks
SecurityTracker Alert ID:  1009428
SecurityTracker URL:  http://securitytracker.com/id/1009428
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Mar 15 2004
Impact:   Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Exploit Included:  Yes  
Version(s): 1.5.1
Description:   An input validation vulnerability was reported in YaBB SE. A remote user can conduct cross-site scripting attacks.

Cheng Peng Su reported that the software does not properly filter scripting code in the [glow] and [shadow] tags. A remote user can submit specially crafted content so that when a target user views the affected message, arbitrary scripting code will be executed by the target user's browser. The code will originate from the site running the YaBB SE software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

A demonstration exploit is provided:

[glow=red);background:url(javascript:alert(document.cookie));filter:glow(color=red,2,300]Big Exploit[/glow]

[shadow=red);background:url(javascript:alert(document.cookie));filter:shadow(color=red,left,300]Big Exploit[/shadow]

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the YaBB SE software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.
Solution:   No solution was available at the time of this entry.
Vendor URL:  www.yabbse.org/ (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  YaBB/YaBBse Cross Site Scripting Vulnerability





#####################################################################

 Advisory Name : YaBB/YaBBse Cross Site Scripting Vulnerability
  Release Date : Mar 14,2004 
   Application : YaBB/YaBBse
       Test On : YaBB 1 Gold(SP1.3)
                 YaBB SE 1.5.1 Final
    Vendor URL : http://www.yabbforum.com/
                 http://www.yabbse.org/
      Discover : Cheng Peng Su(apple_soup_at_msn.com)
     
#####################################################################

  Proof of conecpt:
      The problem is in [glow] and [shadow] tag,yabb doesn't filter
   the charactor in this tag,attack needn't visitor to click any 
   links,just when the vistor read the thread,XSS code will be 
   executed.
  
  Exploit:
   [glow=red);background:url(javascript:alert(document.cookie));filte
   r:glow(color=red,2,300]Big Exploit[/glow]
   [shadow=red);background:url(javascript:alert(document.cookie));fil
   ter:shadow(color=red,left,300]Big Exploit[/shadow]
   
  Contact:
   Cheng Peng Su
   Class 1,Senior 2,High school attached to Wuhan University
   Wuhan,Hubei,China(430072)
   apple_soup_at_msn.com
   
      
 
   

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC