SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Server/CGI)  >   Apache HTTPD Vendors:   Apache Software Foundation
(OpenBSD Issues Fix) Apache mod_access Parsing Flaw May Fail to Enforce Allow/Deny Rules
SecurityTracker Alert ID:  1009422
SecurityTracker URL:  http://securitytracker.com/id/1009422
CVE Reference:   CVE-2003-0993   (Links to External Site)
Date:  Mar 14 2004
Impact:   Disclosure of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.3.29 and prior versions
Description:   A vulnerability was reported in Apache 1.3 in mod_access. Certain allow or deny rules may fail on big-endian 64-bit platforms.

It is reported that when IP addresses are specified without a netmask in an Allow or Deny rule, the server may fail to match the proper rule. As a result, access may be incorrectly granted or denied in these cases.

Only big-endian 64-bit platforms are affected, the report said.

This flaw was independently reported by TTSG Internet Services and by Henning Brauer from the OpenBSD team.

Impact:   A remote user may be able to access certain files or directories if an access rule fails. Also, a remote user may be incorrectly denied access to certain files or directories if an access rule fails.
Solution:   OpenBSD has issued patches:

ftp://ftp.openbsd.org/pub/OpenBSD/patches/3.4/common/014_httpd2.patch
ftp://ftp.openbsd.org/pub/OpenBSD/patches/3.3/common/019_httpd2.patch

Only sparc64 implementations are affected.

Vendor URL:  httpd.apache.org/ (Links to External Site)
Cause:   Access control error
Underlying OS:  UNIX (OpenBSD)
Underlying OS Comments:  3.3, 3.4; sparc64 only

Message History:   This archive entry is a follow-up to the message listed below.
Mar 8 2004 Apache mod_access Parsing Flaw May Fail to Enforce Allow/Deny Rules



 Source Message Contents

Subject:  OpenBSD httpd security fix


 > SECURITY FIX: March 13, 2004

 > Due to a bug in the parsing of Allow/Deny rules for httpd(8)'s access module, using IP
 > addresses without a netmask on big endian 64-bit platforms causes the rules to fail to
 > match. This only affects sparc64.
 > A source code patch exists which remedies the problem.

ftp://ftp.openbsd.org/pub/OpenBSD/patches/3.4/common/014_httpd2.patch
ftp://ftp.openbsd.org/pub/OpenBSD/patches/3.3/common/019_httpd2.patch

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC