SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Firewall)  >   BlackICE Vendors:   Internet Security Systems
ISS BlackICE ICQ Buffer Overflow Yields SYSTEM Level Access to Remote Users
SecurityTracker Alert ID:  1009347
SecurityTracker URL:  http://securitytracker.com/id/1009347
CVE Reference:   CVE-2004-0362   (Links to External Site)
Updated:  Mar 23 2004
Original Entry Date:  Mar 9 2004
Impact:   Execution of arbitrary code via network, Root access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): Agent for Server 3.6 ecf and before, PC Protection 3.6 ccf and before, and Server Protection 3.6 ccf and before
Description:   A buffer overflow vulnerability was reported in BlackICE in the processing of ICQ response messages. A remote user can gain SYSTEM level access on the target system.

eEye Digital Security reported that they discovered a vulnerability in ISS RealSecure and ISS BlackICE. ISS confirmed that the component does not properly parse the ICQ protocol. A remote user can send a specially crafted packet to a target system running BlackICE to trigger the flaw and execute arbitrary code on the target system.

According to the report, a remote user can gain SYSTEM level access on the target system.

The ISS advisory is available at:

xforce.iss.net/xforce/alerts/id/166

Impact:   A remote user can gain SYSTEM level access on the target system.
Solution:   ISS has released a fix, available at the ISS Download Center:

http://www.iss.net/download

The following fixes are available:

BlackICE PC Protection 3.6 ccg
BlackICE Server Protection 3.6 ccg

Vendor URL:  xforce.iss.net/xforce/alerts/id/166 (Links to External Site)
Cause:   Boundary error
Underlying OS:  Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Mar 20 2004 (A Worm is Spreading) ISS BlackICE ICQ Buffer Overflow Yields SYSTEM Level Access to Remote Users
A worm (Witty.Worm) is targeting vulnerable systems.



 Source Message Contents

Subject:  http://www.eeye.com/html/Research/Upcoming/20040308.html


http://www.eeye.com/html/Research/Upcoming/20040308.html

eEye Digital Security reported that they have discovered a vulnerability in ISS RealSecure 
and ISS BlackICE.  The cause of the vulnerability was not disclosed pending vendor 
notification and correction.

According to the report, a remote user can gain SYSTEM level access on the target system.

The vendor has reportedly been notified.

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2022, SecurityGlobal.net LLC