SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (File Transfer/Sharing)  >   fsp Vendors:   Su, Wen-King
fsp Input Validation Flaw Lets Remote Users Traverse the Directory
SecurityTracker Alert ID:  1008635
SecurityTracker URL:  http://securitytracker.com/id/1008635
CVE Reference:   CVE-2003-1022   (Links to External Site)
Updated:  Jan 16 2004
Original Entry Date:  Jan 7 2004
Impact:   Disclosure of system information, Disclosure of user information

Version(s): 2.8.1b17 and previous versions
Description:   An input validation vulnerability was reported in fsp. A remote user can access files located outside of the fsp root directory.

It is reported that there is a directory traversal flaw in validate_path(). A remote user can reportedly escape from the fsp root directory.

Impact:   A remote user can access files located outside of the fsp root directory.
Solution:   No solution was available at the time of this entry.
Cause:   Access control error, Input validation error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Jan 7 2004 (Debian Issues Fix) fsp Input Validation Flaw Lets Remote Users Traverse the Directory
Debian has released a fix.



 Source Message Contents

Subject:  fsp


CVE: CAN-2003-1022 CAN-2004-0011

Debian reported two vulnerabilities in fsp.

1) A remote user can exploit a directory traversal flaw in validate_path() to escape from 
the FSP root directory (CAN-2003-1022).

2) A remote user can exploit a buffer overflow to execute arbitrary code (CAN-2004-0011).


 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC