SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   CVS Vendors:   GNU [multiple authors]
(Gentoo Issues Fix) CVS pserver 'passwd' File May Let Local Users Run Code with Root Privileges
SecurityTracker Alert ID:  1008569
SecurityTracker URL:  http://securitytracker.com/id/1008569
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Dec 29 2003
Impact:   Execution of arbitrary code via local system, Root access via local system
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.11.10 and prior versions
Description:   A vulnerability was reported in the CVS pserver. A local user with write access to the CVS password file may be able to execute arbitrary code with root privileges.

It is reported that a local user with write access to the $CVSROOT/CVSROOT/passwd file can cause pserver to run with root privileges, allowing the user to execute arbitrary code with root privileges.

Impact:   A local user with write access to the CVSROOT/passwd file can execute arbitrary code with root privileges.
Solution:   Gentoo has released a fix and indicates that all Gentoo Linux users with cvs installed updated to use cvs-1.11.11 or higher:

emerge sync
emerge -pv '>=dev-util/cvs-1.11.11'
emerge '>=dev-util/cvs-1.11.11'
emerge clean

Vendor URL:  ccvs.cvshome.org/servlets/NewsItemView?newsID=88 (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Dec 29 2003 CVS pserver 'passwd' File May Let Local Users Run Code with Root Privileges



 Source Message Contents

Subject:  [gentoo-announce] GLSA: cvs (200312-08)



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


- --------------------------------------------------------------------------
GENTOO LINUX SECURITY ANNOUNCEMENT 200312-08
- --------------------------------------------------------------------------

GLSA:        200312-08
package:     dev-util/cvs
summary:     Fix for possible root compromise when using CVS pserver
severity:    high
Gentoo bug:  36142
date:        2003-12-28
exploit:     unknown
affected:    <=1.11.10
fixed:       >=1.11.11


DESCRIPTION:

Quote from <http://ccvs.cvshome.org/servlets/NewsItemView?newsID=88>:

   "Stable CVS 1.11.11 has been released. Stable releases contain only
   bug fixes from previous versions of CVS. This release adds code to
   the CVS server to prevent it from continuing as root after a user
   login, as an extra failsafe against a compromise of the
   CVSROOT/passwd file. Previously, any user with the ability to write
   the CVSROOT/passwd file could execute arbitrary code as the root
   user on systems with CVS pserver access enabled. We recommend this
   upgrade for all CVS servers!"


SOLUTION:

All Gentoo Linux machines with cvs installed should be updated to use
cvs-1.11.11 or higher.

        emerge sync
        emerge -pv '>=dev-util/cvs-1.11.11'
        emerge '>=dev-util/cvs-1.11.11'
        emerge clean


// end

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3 (Darwin)

iD8DBQE/79SAnt0v0zAqOHYRAuWTAJ9UY/lAvsKQRtHLQZr/zDUf5eok6wCgumZt
ICbAjuPbALouwsdG16pqS6s=
=UQlf
-----END PGP SIGNATURE-----


 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC