SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   CVS Vendors:   GNU [multiple authors]
(Gentoo Issues Fix) CVS Input Validation Flaw May Let Remote Users Send Malformed Module Requests to Create Root Directories and Files
SecurityTracker Alert ID:  1008450
SecurityTracker URL:  http://securitytracker.com/id/1008450
CVE Reference:   CVE-2003-0977   (Links to External Site)
Date:  Dec 11 2003
Impact:   Modification of system information, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 1.11.10
Description:   A vulnerability was reported in CVS. A remote user may be able to cause CVS to create files and directories in the root directory.

It is reported that a remote user can submit a specially crafted and malformed module request that may cause the CVS server to attempt to create directories and possibly files at the root of the filesystem where the CVS repository is located. The report indicates that the permissions of the underlying filesystem will usually prevent the creation of these "misplaced directories."

The vendor reports that there are no known exploits for this flaw.

Impact:   A remote user may be able to cause CVS to create directories and potentially files in the filesystem root directory.
Solution:   Gentoo has released a fix and recommends that all Gentoo Linux users of cvs update to cvs-1.11.10 or higher:

emerge sync
emerge -pv '>=dev-util/cvs-1.11.10'
emerge '>=dev-util/cvs-1.11.10'
emerge clean

Vendor URL:  ccvs.cvshome.org/servlets/NewsItemView?newsID=84&JServSessionIdservlets=8u3x1myav1 (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Dec 9 2003 CVS Input Validation Flaw May Let Remote Users Send Malformed Module Requests to Create Root Directories and Files



 Source Message Contents

Subject:  [gentoo-announce] GLSA: cvs (200312-04)



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


- --------------------------------------------------------------------------
GENTOO LINUX SECURITY ANNOUNCEMENT 200312-04
- --------------------------------------------------------------------------

GLSA:        200312-04
package:     dev-util/cvs
summary:     Fix for malformed module request vulnerability in cvs
severity:    minimal
Gentoo bug:  35371
date:        2003-12-08
CVE:         CAN-2003-0977
exploit:     unknown
affected:    <=1.11.9
fixed:       >=1.11.10


DESCRIPTION:

Quote from <http://ccvs.cvshome.org/servlets/NewsItemView?newsID=84>:

   Stable CVS 1.11.10 has been released. Stable releases contain only
   bug fixes from previous versions of CVS. This release fixes a
   security issue with no known exploits that could cause previous
   versions of CVS to attempt to create files and directories in the
   filesystem root. This release also fixes several issues relevant to
   case insensitive filesystems and some other bugs. We recommend this
   upgrade for all CVS clients and servers!"


SOLUTION:

All Gentoo Linux machines with cvs installed should be updated to use
cvs-1.11.10 or higher.

        emerge sync
        emerge -pv '>=dev-util/cvs-1.11.10'
        emerge '>=dev-util/cvs-1.11.10'
        emerge clean


// end

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3 (Darwin)

iD8DBQE/2BrHnt0v0zAqOHYRAt7HAJ9wVNUmbdvS5H4cyUMufSFLsAuhOACfRGWr
SuM+gRSKU69MybE6PRtYSrg=
=SQFw
-----END PGP SIGNATURE-----


 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC