SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Game)  >   Omega Vendors:   Brothers, Laurence
Omega-rpg Game Buffer Overflows Let Local Users Gain Elevated Privileges
SecurityTracker Alert ID:  1008235
SecurityTracker URL:  http://securitytracker.com/id/1008235
CVE Reference:   CVE-2003-0932   (Links to External Site)
Date:  Nov 19 2003
Impact:   Execution of arbitrary code via local system, User access via local system

Version(s): 0.90
Description:   A buffer overflow was reported in the Omega-rpg game software. A local user can gain elevated privileges on the target system.

It is reported that a local user can set a specially crafted command line argument or environment variable to trigger the buffer overflow. A local user can execute arbitrary code with 'games' group privileges.

Debian credits Steve Kemp with discovering this flaw.

Impact:   A local user can execute arbitrary code with 'games' group privileges.
Solution:   No solution was available at the time of this entry.
Cause:   Boundary error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Nov 19 2003 (Debian Issues Fix) Omega-rpg Game Buffer Overflows Let Local Users Gain Elevated Privileges
Debian has released a fix.



 Source Message Contents

Subject:  CVE-2003-0932


Debian reported:

"Steve Kemp discovered a buffer overflow in the commandline and
environment variable handling of omega-rpg, a text-based rogue-style
game of dungeon exploration, which could lead a local attacker to gain
unauthorised access to the group games."




 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC