SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Game)  >   Conquest Vendors:   Poskanzer, Jef et al
(Debian Issues Fix) Conquest Game Buffer Overflows Let Local Users Obtain Elevated Privileges
SecurityTracker Alert ID:  1008130
SecurityTracker URL:  http://securitytracker.com/id/1008130
CVE Reference:   CVE-2003-0933   (Links to External Site)
Date:  Nov 10 2003
Impact:   Execution of arbitrary code via local system, User access via local system
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   Multiple buffer overflows were reported in the Conquest game. A local user may be able to obtain elevated privileges on the system.

It is reported that the software does not properly validate certain environment variables. A local user can set a specially crafted value to execute arbitrary code with 'conquest' user privileges.

Steve Kemp is credited with discovery. At least one of the buffer overflows was also reported in March 1998 by "bst@INAME.COM".

Impact:   A local user can gain 'conquest' user privileges on the target system.
Solution:   Debian has released a fix for the stable distribution (woody) in version 7.1.1-6woody1 and for the unstable distribution (sid) in version 7.2-5.

Debian GNU/Linux 3.0 alias woody:

Source archives:

http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1-6woody1.dsc
Size/MD5 checksum: 606 89c7be20d34d9176d18eb51f28c7806e
http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1-6woody1.diff.gz
Size/MD5 checksum: 32749 27d90e0b6719579833cb064a2b70dcdb
http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1.orig.tar.gz
Size/MD5 checksum: 255029 c02891f6c0c4b8c73a82c1c8185e3025

Alpha architecture:

http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1-6woody1_alpha.deb
Size/MD5 checksum: 366064 b6d212bd4a4880488195d47002e66981

ARM architecture:

http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1-6woody1_arm.deb
Size/MD5 checksum: 227160 42399fea69c68ce63890e63b1b6c00ef

Intel IA-32 architecture:

http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1-6woody1_i386.deb
Size/MD5 checksum: 228846 f03fd6daf700e6f3bf8def68eff30d72

Intel IA-64 architecture:

http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1-6woody1_ia64.deb
Size/MD5 checksum: 402110 ffbff5ca106ee2d41b28aa15e61f74ce

HP Precision architecture:

http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1-6woody1_hppa.deb
Size/MD5 checksum: 260870 1348a3b191e52a84302ee6304654007f

Motorola 680x0 architecture:

http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1-6woody1_m68k.deb
Size/MD5 checksum: 215282 02fc3e118af479c039dde99cf400dac7

Big endian MIPS architecture:

http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1-6woody1_mips.deb
Size/MD5 checksum: 277570 a538cc763893262f56dbcc247d63f75f

Little endian MIPS architecture:

http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1-6woody1_mipsel.deb
Size/MD5 checksum: 275324 ca3d4e2831592b7a0a9b302845895699

PowerPC architecture:

http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1-6woody1_powerpc.deb
Size/MD5 checksum: 267460 6c14f9505b9a70a26b251086fb0a4283

IBM S/390 architecture:

http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1-6woody1_s390.deb
Size/MD5 checksum: 241432 f427b9ce0febfe66370b773c84e30a2e

Sun Sparc architecture:

http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1-6woody1_sparc.deb
Size/MD5 checksum: 302096 50f45c32dc171f547ade2d0439e3ebe0

Vendor URL:  www.debian.org/security/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Debian)
Underlying OS Comments:  3.0

Message History:   This archive entry is a follow-up to the message listed below.
Nov 10 2003 Conquest Game Buffer Overflows Let Local Users Obtain Elevated Privileges



 Source Message Contents

Subject:  [SECURITY] [DSA 398-1] New conquest packages fix local conquest exploit


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 398-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
November 10th, 2003                     http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : conquest
Vulnerability  : buffer overlow
Problem-Type   : local
Debian-specific: no
CVE Id         : CAN-2003-0933

Steve Kemp discovered a buffer overflow in the environment variable
handling of conquest, a curses based, real-time, multi-player space
warfare game, which could lead a local attacker to gain unauthorised
access to the group conquest.

For the stable distribution (woody) this problem has been fixed in
version 7.1.1-6woody1.

For the unstable distribution (sid) this problem has been fixed in
version 7.2-5.

We recommend that you upgrade your conquest package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.0 alias woody
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1-6woody1.dsc
      Size/MD5 checksum:      606 89c7be20d34d9176d18eb51f28c7806e
    http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1-6woody1.diff.gz
      Size/MD5 checksum:    32749 27d90e0b6719579833cb064a2b70dcdb
    http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1.orig.tar.gz
      Size/MD5 checksum:   255029 c02891f6c0c4b8c73a82c1c8185e3025

  Alpha architecture:

    http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1-6woody1_alpha.deb
      Size/MD5 checksum:   366064 b6d212bd4a4880488195d47002e66981

  ARM architecture:

    http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1-6woody1_arm.deb
      Size/MD5 checksum:   227160 42399fea69c68ce63890e63b1b6c00ef

  Intel IA-32 architecture:

    http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1-6woody1_i386.deb
      Size/MD5 checksum:   228846 f03fd6daf700e6f3bf8def68eff30d72

  Intel IA-64 architecture:

    http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1-6woody1_ia64.deb
      Size/MD5 checksum:   402110 ffbff5ca106ee2d41b28aa15e61f74ce

  HP Precision architecture:

    http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1-6woody1_hppa.deb
      Size/MD5 checksum:   260870 1348a3b191e52a84302ee6304654007f

  Motorola 680x0 architecture:

    http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1-6woody1_m68k.deb
      Size/MD5 checksum:   215282 02fc3e118af479c039dde99cf400dac7

  Big endian MIPS architecture:

    http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1-6woody1_mips.deb
      Size/MD5 checksum:   277570 a538cc763893262f56dbcc247d63f75f

  Little endian MIPS architecture:

    http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1-6woody1_mipsel.deb
      Size/MD5 checksum:   275324 ca3d4e2831592b7a0a9b302845895699

  PowerPC architecture:

    http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1-6woody1_powerpc.deb
      Size/MD5 checksum:   267460 6c14f9505b9a70a26b251086fb0a4283

  IBM S/390 architecture:

    http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1-6woody1_s390.deb
      Size/MD5 checksum:   241432 f427b9ce0febfe66370b773c84e30a2e

  Sun Sparc architecture:

    http://security.debian.org/pool/updates/main/c/conquest/conquest_7.1.1-6woody1_sparc.deb
      Size/MD5 checksum:   302096 50f45c32dc171f547ade2d0439e3ebe0


  These files will probably be moved into the stable distribution on
  its next revision.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3 (GNU/Linux)

iD8DBQE/r1n8W5ql+IAeqTIRArGqAKCQk34qRR8mmsAymAZJ2t0ck3zn5wCfa0bD
0bpty11ag9D9+Z6fpkkccDc=
=haJH
-----END PGP SIGNATURE-----


-- 
To UNSUBSCRIBE, email to debian-security-announce-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC