SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Commerce)  >   A-CART Vendors:   alanward.net
A-CART Input Validation Flaw in 'signin.asp' Permits Remote Cross-Site Scripting Attacks
SecurityTracker Alert ID:  1007826
SecurityTracker URL:  http://securitytracker.com/id/1007826
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Sep 27 2003
Impact:   Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Exploit Included:  Yes  
Version(s): 2.0 and Pro
Description:   G00db0y from Zone-h Security Team reported an input validation vulnerability in A-CART. A remote user can conduct cross-site scripting attacks.

It is reported that the 'signin.asp' script does not properly filter HTML code from user-supplied input in the 'msg' variable. A remote user can create a specially crafted URL that, when loaded by a target user, will cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the A-CART software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

A demonstration exploit URL is provided:

http://[target]/acartpath/signin.asp?msg=<script>alert('Zone-h')</script>

The vendor has reportedly been notified.

The original Zone-h advisory is available at:

http://www.zone-h.org/en/advisories/read/id=3156/

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the vulnerable A-CART software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.
Solution:   No solution was available at the time of this entry.
Vendor URL:  www.alanward.net/acart/ (Links to External Site)
Cause:   Input validation error
Underlying OS:  Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  ZH2003-29SA (security advisory): A-Cart 2.0 and A-Cart Pro XSS Vulnerability



ZH2003-29SA (security advisory): A-Cart 2.0 and A-Cart Pro XSS Vulnerability

Published: 27 september 2003

Released: 27 september 2003

Name: A-Cart

Affected Systems: 2.0 and Pro

Issue: Remote attackers can inject XSS script

Author: G00db0y@zone-h.org

Vendor: http://www.alanward.net/


Description

***********

Zone-h Security Team has discovered a flaw in A-Cart v2.0 and in A-Cart Pro (and older 
versions?). "A-CART is a cost efficint solution to your shopping cart needs."


Details

*******


It's possibile to inject XSS script in msg variable in the signin.asp file

For example try this:

http://examplesite/acartpath/signin.asp?msg=<script>alert('Zone-h')</script>


Solution:

*********

The vendor has been contacted and a patch is not produced yet



Suggestions:

************

Filter the msg variable.

G00db0y - www.zone-h.org admin

Original advisory here: http://www.zone-h.org/en/advisories/read/id=3156/


 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC