SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Server/CGI)  >   CGIC Vendors:   Boutell.com
CGIC Library Buffer Overflow May Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1006606
SecurityTracker URL:  http://securitytracker.com/id/1006606
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Apr 20 2003
Impact:   Denial of service via network, Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 2.0, 2.01
Description:   A buffer overflow vulnerability was reported in the CGIC ANSI C library. A remote user may be able to cause an application that uses the library to crash or possibly execute arbitrary code.

If the contents of the HTTP_COOKIE environment variable is identical to the name of a cookie requested with the library's cgiCookieString() function, the overflow can be triggered. Whether or not this is exploitable depends on the application that uses the library.

The vendor credits Nicolas Tomadakis with reporting the flaw.

Impact:   A remote user could cause an application that uses the library to crash or possibly execute arbitrary code. The specific impact will depend on the application that uses the library. Some applications may not be affected.
Solution:   The vendor has released a fixed version (2.02), available at:

http://www.boutell.com/cgic/cgic202.tar.gz
http://www.boutell.com/cgic/cgic202.zip

Vendor URL:  www.boutell.com/cgic/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  CGIC ANSI C library buffer overflow


http://www.boutell.com/cgic/

The vendor reported a buffer overflow vulnerability in the CGIC ANSI C library.  If the 
contents of the HTTP_COOKIE environment variable was identical to the name of a cookie 
requested with the cgiCookieString() function, the overflow can be triggered.

The vendor credits Nicolas Tomadakis with reporting the flaw.

Version 2.0 and 2.01 are affected.

http://www.boutell.com/cgic/cgic202.tar.gz
http://www.boutell.com/cgic/cgic202.zip





 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC