SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Security)  >   kadmind (please use Kerberos) Vendors:   Royal Institute of Technology
(Conectiva Issues Fix) Heimdal Kerberos 'kadmind' Buffer Overflow Lets Remote Users Execute Arbitrary Code With Root Privileges
SecurityTracker Alert ID:  1005555
SecurityTracker URL:  http://securitytracker.com/id/1005555
CVE Reference:   CVE-2002-1235   (Links to External Site)
Date:  Nov 7 2002
Impact:   Execution of arbitrary code via network, Root access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 0.5.1
Description:   A buffer overflow vulnerability was reported in 'kadmind', the administrative access server for the Kerberos database in the Heimdal distribution. A remote user may be able to execute arbitrary code on the system with root level privileges.

It is reported that kadmind in Heimdal releases earlier than 0.5.1 has a buffer overflow in the kerberos version 4 compatibility code. If compiled with support for the Kerberos 4 kadmin protocol, kadmind is vulnerable.

A remote user can cause arbitrary code to be executed with root level privileges.

To determine if kadmind is vulnerable you can run:

# /usr/heimdal/libexec/kadmind --version
kadmind (Heimdal 0.5.1, KTH-KRB 1.2)
Copyright (c) 1999-2002 Kungliga Tekniska H gskolan
Send bug-reports to heimdal-bugs@pdc.kth.se

Non-vulnerable versions reportedly include Heimdal 0.5.1 and binaries that do *not* show a Kerberos 4 version string (KTH-KRB 1.2 in the example).

Impact:   A remote user can execute arbitrary code with root privileges to gain root access on the system.
Solution:   Conectiva has released a fix.

ftp://atualizacoes.conectiva.com.br/8/SRPMS/krb5-1.2.3-3U8_3cl.src.rpm
ftp://atualizacoes.conectiva.com.br/8/RPMS/krb5-1.2.3-3U8_3cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/8/RPMS/krb5-apps-clients-1.2.3-3U8_3cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/8/RPMS/krb5-apps-servers-1.2.3-3U8_3cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/8/RPMS/krb5-client-1.2.3-3U8_3cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/8/RPMS/krb5-devel-1.2.3-3U8_3cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/8/RPMS/krb5-devel-static-1.2.3-3U8_3cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/8/RPMS/krb5-doc-1.2.3-3U8_3cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/8/RPMS/krb5-server-1.2.3-3U8_3cl.i386.rpm

Vendor URL:  www.pdc.kth.se/heimdal/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Conectiva)
Underlying OS Comments:  8

Message History:   This archive entry is a follow-up to the message listed below.
Oct 22 2002 Heimdal Kerberos 'kadmind' Buffer Overflow Lets Remote Users Execute Arbitrary Code With Root Privileges



 Source Message Contents

Subject:  [conectiva-updates] [CLA-2002:534] Conectiva Linux Security Announcement - krb5


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
CONECTIVA LINUX SECURITY ANNOUNCEMENT 
- --------------------------------------------------------------------------

PACKAGE   : krb5
SUMMARY   : Buffer overflow vulnerability in the Kerberos 4 administration daemon
DATE      : 2002-10-25 20:38:00
ID        : CLA-2002:534
RELEVANT
RELEASES  : 8

- -------------------------------------------------------------------------

DESCRIPTION
 The "krb5" packages are MIT's[1] implementation of the Kerberos 5
 authentication protocol. 
 
 There is a buffer overflow vulnerability[2][3] in the Kerberos 4
 remote administration service (kadmind4) that could be used by a
 remote attacker to execute arbitrary commands on the server with root
 privileges.
 
 The daemon which implements this service, kadmind4, is included in
 our krb5-server package, but not used by default. The package
 defaults to using the kadmind daemon, which is not vulnerable to this
 problem. Only administrators who explicitly run kadmind4 will be at
 risk.
 
 The authors released an advisory[2] with a patch which fixes the
 vulnerability. This patch has been applied to the updated packages
 below.


SOLUTION
 All Kerberos users should upgrade their packages immediately.
 
 IMPORTANT: if the kadmind4 daemon is in use, it needs to be manually
 restarted after upgrading the packages.
 
 
 REFERENCES
 1.http://web.mit.edu/Kerberos/www/index.html
 2.http://web.mit.edu/Kerberos/www/advisories/MITKRB5-SA-2002-002-kadm4.txt
 3.http://www.cert.org/advisories/CA-2002-29.html
 4.http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2002-1235


DIRECT DOWNLOAD LINKS TO THE UPDATED PACKAGES
ftp://atualizacoes.conectiva.com.br/8/SRPMS/krb5-1.2.3-3U8_3cl.src.rpm
ftp://atualizacoes.conectiva.com.br/8/RPMS/krb5-1.2.3-3U8_3cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/8/RPMS/krb5-apps-clients-1.2.3-3U8_3cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/8/RPMS/krb5-apps-servers-1.2.3-3U8_3cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/8/RPMS/krb5-client-1.2.3-3U8_3cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/8/RPMS/krb5-devel-1.2.3-3U8_3cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/8/RPMS/krb5-devel-static-1.2.3-3U8_3cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/8/RPMS/krb5-doc-1.2.3-3U8_3cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/8/RPMS/krb5-server-1.2.3-3U8_3cl.i386.rpm


ADDITIONAL INSTRUCTIONS
 Users of Conectiva Linux version 6.0 or higher may use apt to perform 
 upgrades of RPM packages:
 - add the following line to /etc/apt/sources.list if it is not there yet
   (you may also use linuxconf to do this):

 rpm [cncbr] ftp://atualizacoes.conectiva.com.br 6.0/conectiva updates

(replace 6.0 with the correct version number if you are not running CL6.0)

 - run:                 apt-get update
 - after that, execute: apt-get upgrade

 Detailed instructions reagarding the use of apt and upgrade examples 
 can be found at http://distro.conectiva.com.br/atualizacoes/#apt?idioma=en


- -------------------------------------------------------------------------
All packages are signed with Conectiva's GPG key. The key and instructions
on how to import it can be found at 
http://distro.conectiva.com.br/seguranca/chave/?idioma=en
Instructions on how to check the signatures of the RPM packages can be
found at http://distro.conectiva.com.br/seguranca/politica/?idioma=en
- -------------------------------------------------------------------------
All our advisories and generic update instructions can be viewed at
http://distro.conectiva.com.br/atualizacoes/?idioma=en

- -------------------------------------------------------------------------
subscribe: conectiva-updates-subscribe@papaleguas.conectiva.com.br
unsubscribe: conectiva-updates-unsubscribe@papaleguas.conectiva.com.br
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE9ucgZ42jd0JmAcZARAn1zAKCFNLJcV73WTS081IgZdKxX/WTdEACggdGd
DgFAKZ20FwToaXE5nInULrs=
=k2hw
-----END PGP SIGNATURE-----



 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC