SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Security)  >   Compaq Secure Web Server Vendors:   Modssl.org
(Compaq Issues Fix for Compaq Secure Web Server) 'mod_ssl' Security Package for Apache Web Server Has Buffer Overflow That Can Be Triggered By Remote Users
SecurityTracker Alert ID:  1003931
SecurityTracker URL:  http://securitytracker.com/id/1003931
CVE Reference:   CVE-2002-0082   (Links to External Site)
Date:  Mar 31 2002
Impact:   Execution of arbitrary code via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.2, 1.1-1, 1.0-1
Description:   A vulnerability was reported in the 'mod_ssl' package for the Apache web server. A remote user may be able to overflow a buffer. The potential impact is not yet know.

It is reported that a remote user may be able to trigger a buffer overflow in the DBM and SHMHT session cache by using very large certificate chains. This is reportedly due to the unbounded nature of ASN.1 representations that could overflow a large but statically allocated buffer.

It is not yet clear if remote code execution is feasible.

Impact:   A remote user may be able to trigger a buffer overflow in mod_ssl. It is not yet clear if remote code execution is feasible.
Solution:   The vendor has released a fix for Compaq Secure Web Server (CSWS).

For CSWS for OpenVMS V7.1-2 or later:

A Compaq Secure Web Server security update kit is available for download at:
http://www.openvms.compaq.com/openvms/products/ips/apache/csws_patches.html

Installed Version, Update Kit

CSWS V1.2, CSWS12_UPDATE V1.0
CSWS V1.1-1, CSWS111_UPDATE V1.0
CSWS V1.0-1, CSWS101_UPDATE V1.0

For TRU64 UNIX for V5.0a or later:

A Compaq Secure Web Server security update kit is available for download at:
http://tru64unix.compaq.com/internet/download.htm#sws_v582

select and install the CSWS (Compaq Secure Web Server) kit V5.8.2


Installed Version, Install Updated Server Kit

CSWS V5.5.2, CSWS V5.8.2

After completing the update, Compaq strongly recommends that you perform an immediate backup of your system disk so that any subsequent restore operations begin with updated software. Otherwise, you must reapply the patch after a future restore operation. Also, if at some future time you upgrade your system to a later patch version, you may need to reapply the appropriate patch.

Vendor URL:  www.modssl.org/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  OpenVMS, UNIX (Tru64)
Underlying OS Comments:  OpenVMS V7.1-2 or later; TRU64 UNIX V5.0A or later

Message History:   This archive entry is a follow-up to the message listed below.
Feb 26 2002 'mod_ssl' Security Package for Apache Web Server Has Buffer Overflow That Can Be Triggered By Remote Users



 Source Message Contents

Subject:  [security bulletin] - (SSRT0817, SSRT0821) Potential Security Vulnerabilities with Compaq Secure Web Server (PHP and apache/mod_ssl)


 
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

TITLE:  (SSRT0817, SSRT0821) Potential Security Vulnerabilities
              with Compaq Secure Web Server (PHP and apache/mod_ssl)

Posted at http://ftp.support.compaq.com/patches/.new/security.shtml

NOTICE: There are no restrictions for distribution of this Bulletin
        provided that it remains complete and intact.

RELEASE DATE:  March 2002

SOURCE:
            Compaq Computer Corporation
            Compaq Services
            Software Security Response Team

X-REFERENCE: CVE Candidate - PHP (CAN-2002-0081) ,
             Apache/mod_ssl(CAN-2002-0082)

PROBLEM SUMMARY:

Compaq was recently notified of two potential vulnerabilities
that impact Compaq's distributed Secure Web Server (CSWS) for
OpenVMS and TRU64 UNIX.

     (SSRT0817) PHP

PHP (Hypertext Preprocessor scripting language). PHP does not
perform proper bounds checking on in functions related to
Form-based File Uploads in HTML to decode MIME encoded files.
This potential overflow vulnerability may allow arbitrary code
to be executed.



     (SSRT0821) Apache/mod_ssl

Apache/mod_ssl session cache management routines use an unchecked
buffer that could potentially allow an overflow of a session cache
buffer. Thispotential vulnerability may allow arbitrary code to be
executed.

VERSIONS IMPACTED:

     IMPACT:

       CSWS                 (SSRT0817) PHP    (SSRT0821)
                                              Apache/mod_ssl

       OpenVMS V7.1-2
       or
       later                 CSWS_PHP V1.0    CSWS V1.0-1,
                                              CSWS V1.1-1,
                                              CSWS V1.2


       TRU64 UNIX V5.0A
       or
       later                 CSWS V5.5.2       CSWS V5.5.2


        *NOTE:These reported potential vulnerabilities do not
        have an impact to the base operating system in the form
        of elevated permissions or privileges.


     NO IMPACT:

     Himalaya Web Products

     Compaq Management Software Web Products


RESOLUTION:

Compaq has corrected both problems and created patches that are now
available for CSWS (Compaq Secure Web Server) for OpenVMS and TRU64
UNIX.

CSWS for OpenVMS V7.1-2 or later:

A Compaq Secure Web Server security update kit is available for
download at:
http://www.openvms.compaq.com/openvms/products/ips/apache/csws_patches
.html

       (SSRT0817) PHP

       INSTALLED VERSION         UPDATE KIT

       CSWS_PHP 1.0              CSWS_PHP10_UPDATE V1.0


     NOTE: (SSRT0817) PHP - For OpenVMS - if upgrading is not
     possible or a patch cannot be applied immediately, the
     potential PHP overflow vulnerability may be minimized by
     adding the following line to MOD_PHP.CONF file:
     PHP_FLAG file_uploads OFF
     This will prevent using fileuploads, which may not be
     an acceptable short-term solution.

       (SSRT0821) Apache/mod_ssl

       Installed Version   Update Kit

       CSWS V1.2           CSWS12_UPDATE V1.0
       CSWS V1.1-1         CSWS111_UPDATE V1.0
       CSWS V1.0-1         CSWS101_UPDATE V1.0




TRU64 UNIX for V5.0a or later:

A Compaq Secure Web Server security update kit is available for
download at:
http://tru64unix.compaq.com/internet/download.htm#sws_v582
select and install the CSWS (Compaq Secure Web Server) kit V5.8.2


       Installed Version   Install Updated Server Kit

       CSWS V5.5.2          CSWS V5.8.2


After completing the update, Compaq strongly recommends that you
perform an immediate backup of your system disk so that any
subsequent restore operations begin with updated software. Otherwise,
you must reapply the patch after a future restore operation. Also, if
at some future time you upgrade your system to a later patch version,
you may need to reapply the appropriate patch.


SUPPORT:

For further information, contact Compaq Global Services.


SUBSCRIBE:

To subscribe to automatically receive future Security Advisories from
the Compaq's Software Security Response Team via electronic mail:
http://www.support.compaq.com/patches/mailing-list.shtml

REPORT:

To report a potential security vulnerability with any Compaq
supported product, send email mailto:security-ssrt@compaq.com

Compaq appreciates your cooperation and patience. We regret
any inconvenience applying this information may cause. As always,
Compaq urges you to periodically review your system management and
security procedures. Compaq will continue to review and enhance the
security features of its products and work with customers to maintain
and improve the security and integrity of their systems.

"Compaq is broadly distributing this Security Advisory to notify all
users of Compaq products of the important security information
contained in this Advisory. Compaq recommends that all users
determine the applicability of this information to their individual
situations and take appropriate action. Compaq does not warrant that
this information is necessarily accurate or complete for all user
situations and, consequently, Compaq will not be responsible for any
damages resulting from user's use or disregard of the information
provided in this Advisory."

Copyright 2002 Compaq Information Technologies Group, L.P. Compaq
shall not be liable for technical or editorial errors or omissions
contained herein. The information in this document is subject to
change without notice. Compaq and the names of Compaq products
referenced herein are, either, trademarks and/or service marks or
registered trademarks and/or service marks of Compaq Information
Technologies Group, L.P. Other product and company names mentioned
herein may be trademarks and/or service marks of their respective
owners.

-----BEGIN PGP SIGNATURE-----
Version: PGP 7.0.1

iQA/AwUBPKYaXznTu2ckvbFuEQLbTQCfarAsi8kRC4LM8mftiUv84AWBHmYAn1Z7
qdlODoP4yGBrHmi2hIVqr0Ia
=egdQ
-----END PGP SIGNATURE-----


---
You are currently subscribed to security as: **********
To unsubscribe send a blank email to *********************@list.support.compaq.com

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC