SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Zope Vendors:   Digital Creations
Zope Dynamic Web Content Management Tool May Allow Remote Users to Access Certain Unauthorized Data
SecurityTracker Alert ID:  1001519
SecurityTracker URL:  http://securitytracker.com/id/1001519
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  May 11 2001
Impact:   Disclosure of system information, Disclosure of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): up to and including 2.3.2
Description:   It was reported that the Zope dynamic HTML content management tool contains a vulnerability that allows remote users to obtain unauthorized data from the server.

This vulnerability reportedly affects all Zope versions up to and including Zope 2.3.2.

Digital Creations reports that the issue is related to ZClasses in that any user can visit a ZClass declaration and change the ZClass permission mappings for methods and other objects defined within the ZClass. The end result is the potential for unauthorized access within the Zope instance.

Impact:   A remote user can obtain unauthorized access to data within a Zope instance.
Solution:   The vendor has released a hotfix. See the Vendor URL for more information. For Mandrake-specific information, please see the Source Message for details.
Vendor URL:  www.zope.org/Products/Zope/Hotfix_2001-05-01/security_alert (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
(Red Hat Releases Fix) Re: Zope Dynamic Web Content Management Tool May Allow Remote Users to Access Certain Unauthorized Data
Red Hat has released a fix.
(Conectiva Issues Fix) Zope Dynamic Web Content Management Tool May Allow Remote Users to Access Certain Unauthorized Data
The vendor has released a fix.



 Source Message Contents

Subject:  [Security Announce] MDKSA-2001:049 - Zope update


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

________________________________________________________________________

                Linux-Mandrake Security Update Advisory
________________________________________________________________________

Package name:           Zope
Date:                   May 10th, 2001
Advisory ID:            MDKSA-2001:049

Affected versions:      7.1, 7.2, Corporate Server 1.0.1
________________________________________________________________________

Problem Description:

 Another problem was discovered in Zope that fixes a problem with
 ZClasses.  Any user can visit a ZClass declaration and change the
 ZClass permission mappings for methods and other objects defined within
 the ZClass, possibly allowing for unauthorized access within the Zope
 instance.  The Zope Hotfix 2001-05-01 corrects this problem.
________________________________________________________________________

References:

 http://www.zope.org/Products/Zope/Hotfix_2001-05-01/security_alert
________________________________________________________________________

Please verify the update prior to upgrading to ensure the integrity of
the downloaded package.  You can do this with the command:
  rpm --checksig package.rpm
You can get the GPG public key of the Linux-Mandrake Security Team at
  http://www.linux-mandrake.com/en/security/RPM-GPG-KEYS
If you use MandrakeUpdate, the verification of md5 checksum and GPG
signature is performed automatically for you.

Linux-Mandrake 7.1:
c7388c57ea2d9b5fed599fe6b6880376  7.1/RPMS/Zope-2.2.4-1.4mdk.i586.rpm
1c7ec34d3c0b5da483013bc6c9e7872e  7.1/RPMS/Zope-components-2.2.4-1.4mdk.i586.rpm
e294175142ecdee8aa15732b52d69dca  7.1/RPMS/Zope-core-2.2.4-1.4mdk.i586.rpm
511c5105cf998987b0b9a272fe61e352  7.1/RPMS/Zope-pcgi-2.2.4-1.4mdk.i586.rpm
9130510f6f92e10e7c5485381fc00af3  7.1/RPMS/Zope-services-2.2.4-1.4mdk.i586.rpm
e83d1b4e16b5a18f50abb2da6d4a1d40  7.1/RPMS/Zope-zpublisher-2.2.4-1.4mdk.i586.rpm
114eab5a6760b79f054c2158d9c19455  7.1/RPMS/Zope-zserver-2.2.4-1.4mdk.i586.rpm
35126a3cb4586ee1430fa9a36390a388  7.1/RPMS/Zope-ztemplates-2.2.4-1.4mdk.i586.rpm
2335045161bcd5274c9451d8fe90240c  7.1/SRPMS/Zope-2.2.4-1.4mdk.src.rpm

Linux-Mandrake 7.2:
75ad611ab43f12aa87772b0b0de45025  7.2/RPMS/Zope-2.2.4-1.4mdk.i586.rpm
6883ea8e3a6b38606e7bb626e34e9bf0  7.2/RPMS/Zope-components-2.2.4-1.4mdk.i586.rpm
c5ab317f60b5e5aa96ca13f7a8249392  7.2/RPMS/Zope-core-2.2.4-1.4mdk.i586.rpm
b9a674a5f5970d566e3c91b611c2f894  7.2/RPMS/Zope-pcgi-2.2.4-1.4mdk.i586.rpm
bd1b510cc7fd4677d7710f57b6350301  7.2/RPMS/Zope-services-2.2.4-1.4mdk.i586.rpm
f9e5d5900da345d1db37650ce8a6660b  7.2/RPMS/Zope-zpublisher-2.2.4-1.4mdk.i586.rpm
8a70d98a279a030bd65e3685fc3fb6e3  7.2/RPMS/Zope-zserver-2.2.4-1.4mdk.i586.rpm
d56717e58f8c2e1f4f5a31de448c82ca  7.2/RPMS/Zope-ztemplates-2.2.4-1.4mdk.i586.rpm
2335045161bcd5274c9451d8fe90240c  7.2/SRPMS/Zope-2.2.4-1.4mdk.src.rpm

Corporate Server 1.0.1:
c7388c57ea2d9b5fed599fe6b6880376  1.0.1/RPMS/Zope-2.2.4-1.4mdk.i586.rpm
1c7ec34d3c0b5da483013bc6c9e7872e  1.0.1/RPMS/Zope-components-2.2.4-1.4mdk.i586.rpm
e294175142ecdee8aa15732b52d69dca  1.0.1/RPMS/Zope-core-2.2.4-1.4mdk.i586.rpm
511c5105cf998987b0b9a272fe61e352  1.0.1/RPMS/Zope-pcgi-2.2.4-1.4mdk.i586.rpm
9130510f6f92e10e7c5485381fc00af3  1.0.1/RPMS/Zope-services-2.2.4-1.4mdk.i586.rpm
e83d1b4e16b5a18f50abb2da6d4a1d40  1.0.1/RPMS/Zope-zpublisher-2.2.4-1.4mdk.i586.rpm
114eab5a6760b79f054c2158d9c19455  1.0.1/RPMS/Zope-zserver-2.2.4-1.4mdk.i586.rpm
35126a3cb4586ee1430fa9a36390a388  1.0.1/RPMS/Zope-ztemplates-2.2.4-1.4mdk.i586.rpm
2335045161bcd5274c9451d8fe90240c  1.0.1/SRPMS/Zope-2.2.4-1.4mdk.src.rpm
________________________________________________________________________

Bug IDs fixed (see https://qa.mandrakesoft.com for more information):

________________________________________________________________________

To upgrade automatically, use MandrakeUpdate.

If you want to upgrade manually, download the updated package from one
of our FTP server mirrors and upgrade with "rpm -Fvh *.rpm".

You can download the updates directly from one of the mirror sites
listed at:

  http://www.linux-mandrake.com/en/ftp.php3.

Updated packages are available in the "updates/[ver]/RPMS/" directory.
For example, if you are looking for an updated RPM package for
Linux-Mandrake 8.0, look for it in "updates/8.0/RPMS/".  Updated source
RPMs are available as well, but you generally do not need to download
them.

Please be aware that sometimes it takes the mirrors a few hours to
update.

You can view other security advisories for Linux-Mandrake at:

  http://www.linux-mandrake.com/en/security/

If you want to report vulnerabilities, please contact

  security@linux-mandrake.com
________________________________________________________________________

Linux-Mandrake has two security-related mailing list services that
anyone can subscribe to:

security-announce@linux-mandrake.com

  Linux-Mandrake's security announcements mailing list.  Only
  announcements are sent to this list and it is read-only.

security-discuss@linux-mandrake.com

  Linux-Mandrake's security discussion mailing list.  This list is open
  to anyone to discuss Linux-Mandrake security specifically and Linux
  security in general.

To subscribe to either list, send a message to
  sympa@linux-mandrake.com
with "subscribe [listname]" in the body of the message.

To remove yourself from either list, send a message to
  sympa@linux-mandrake.com
with "unsubscribe [listname]" in the body of the message.

To get more information on either list, send a message to
  sympa@linux-mandrake.com
with "info [listname]" in the body of the message.

Optionally, you can use the web interface to subscribe to or unsubscribe
from either list:

  http://www.linux-mandrake.com/en/flists.php3#security
________________________________________________________________________

Type Bits/KeyID     Date       User ID
pub  1024D/22458A98 2000-07-10 Linux Mandrake Security Team
  <security@linux-mandrake.com>


- -----BEGIN PGP PUBLIC KEY BLOCK-----
Version: GnuPG v1.0.5 (GNU/Linux)
Comment: For info see http://www.gnupg.org

mQGiBDlp594RBAC2tDozI3ZgQsE7XwxurJCJrX0L5vx7SDByR5GHDdWekGhdiday
L4nfUax+SeR9SCoCgTgPW1xB8vtQc8/sinJlMjp9197a2iKM0FOcPlkpa3HcOdt7
WKJqQhlMrHvRcsivzcgqjH44GBBJIT6sygUF8k0lU6YnMHj5MPc/NGWt8wCg9vKo
P0l5QVAFSsHtqcU9W8cc7wMEAJzQsAlnvPXDBfBLEH6u7ptWFdp0GvbSuG2wRaPl
hynHvRiE01ZvwbJZXsPsKm1z7uVoW+NknKLunWKB5axrNXDHxCYJBzY3jTeFjsqx
PFZkIEAQphLTkeXXelAjQ5u9tEshPswEtMvJvUgNiAfbzHfPYmq8D6x5xOw1IySg
2e/LBACxr2UJYCCB2BZ3p508mAB0RpuLGukq+7UWiOizy+kSskIBg2O7sQkVY/Cs
iyGEo4XvXqZFMY39RBdfm2GY+WB/5NFiTOYJRKjfprP6K1YbtsmctsX8dG+foKsD
LLFs7OuVfaydLQYp1iiN6D+LJDSMPM8/LCWzZsgr9EKJ8NXiyrQ6TGludXggTWFu
ZHJha2UgU2VjdXJpdHkgVGVhbSA8c2VjdXJpdHlAbGludXgtbWFuZHJha2UuY29t
PohWBBMRAgAWBQI5aefeBAsKBAMDFQMCAxYCAQIXgAAKCRCaqNDQIkWKmK6LAKCy
/NInDsaMSI+WHwrquwC5PZrcnQCeI+v3gUDsNfQfiKBvQSANu1hdulqIRgQQEQIA
BgUCOtNVGQAKCRBZ5w3um0pAJJWQAKDUoL5He+mKbfrMaTuyU5lmRyJ0fwCgoFAP
WdvQlu/kFjphF740XeOwtOqIRgQQEQIABgUCOu8A6QAKCRBynDnb9lq3CnpjAJ4w
Pk0SEE9U4r40IxWpwLU+wrWVugCdFfSPllPpZRCiaC7HwbFcfExRmPa5AQ0EOWnn
7xAEAOQlTVY4TiNo5V/iP0J1xnqjqlqZsU7yEBKo/gZz6/+hx75RURe1ebiJ9F77
9FQbpJ9Epz1KLSXvq974rnVb813zuGdmgFyk+ryA/rTR2RQ8h+EoNkwmATzRxBXV
Jb57fFQjxOu4eNjZAtfII/YXb0uyXXrdr5dlJ/3eXrcO4p0XAAMFBACCxo6Z269s
+A4v8C6Ui12aarOQcCDlV8cVG9LkyatU3FNTlnasqwo6EkaP572448weJWwN6SCX
Vl+xOYLiK0hL/6Jb/O9Agw75yUVdk+RMM2I4fNEi+y4hmfMh2siBv8yEkEvZjTcl
3TpkTfzYky85tu433wmKaLFOv0WjBFSikohGBBgRAgAGBQI5aefvAAoJEJqo0NAi
RYqYid0AoJgeWzXrEdIClBOSW5Q6FzqJJyaqAKC0Y9YI3UFlE4zSIGjcFlLJEJGX
lA==
=0ahQ
- -----END PGP PUBLIC KEY BLOCK-----

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.5 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE6+3ENmqjQ0CJFipgRAtr+AJ9zGUDZ1GOiCXX/BFvp3UXOd4U9ywCgtldw
Qhx+Y2KOuSgcLjbyHiSoGg8=
=vkAH
-----END PGP SIGNATURE-----

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC