SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   WebSVN Vendors:   websvn.tigris.org
WebSVN Input Validation Flaw in getLog() Permits Cross-Site Scripting Attacks
SecurityTracker Alert ID:  1026438
SecurityTracker URL:  http://securitytracker.com/id/1026438
CVE Reference:   CVE-2011-5221   (Links to External Site)
Updated:  Oct 26 2012
Original Entry Date:  Dec 19 2011
Impact:   Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): 2.3.0 and prior versions
Description:   A vulnerability was reported in WebSVN. A remote user can conduct cross-site scripting attacks.

The getLog() function does not properly filter HTML code from user-supplied input before displaying the input. A remote user can create a specially crafted URL that, when loaded by a target user, will cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the WebSVN software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

The 'comp.php', 'diff.php', and 'revision.php' scripts are affected.

The original advisory is available at:

http://st2tea.blogspot.com/2011/12/websvn-cross-site-scripting.html

Sony reported this vulnerability.

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the WebSVN software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.
Solution:   The vendor has issued a fix (2.3.1, in December 2010).

The vendor's advisory is available at:

http://websvn.tigris.org/issues/show_bug.cgi?id=275

Vendor URL:  websvn.tigris.org/ (Links to External Site)
Cause:   Input validation error
Underlying OS:   Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Date:  Mon, 19 Dec 2011 12:37:16 +0000
Subject:  WebSVN


http://packetstormsecurity.org/files/107973/websvn-xss.txt


 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC