SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   FreeType Vendors:   freetype.org
FreeType 2 Font File Processing Errors Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1024266
SecurityTracker URL:  http://securitytracker.com/id/1024266
CVE Reference:   CVE-2010-2498, CVE-2010-2499, CVE-2010-2500, CVE-2010-2519, CVE-2010-2527, CVE-2010-2541   (Links to External Site)
Date:  Jul 30 2010
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 2.4.0 and prior versions
Description:   Several vulnerabilities were reported in FreeType 2. A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can create a specially crafted font file that, when loaded by the target application, will trigger a buffer overflow or other memory management or memory corruption error and execute arbitrary code on the target system. The code will run with the privileges of the target application.

An invalid memory management error in the FreeType font engine can cause code execution [CVE-2010-2498].

An integer overflow in the FreeType font engine can cause code execution [CVE-2010-2500].

Buffer overflows in the FreeType font engine can cause code execution [CVE-2010-2499, CVE-2010-2519].

Buffer overflows in the FreeType demo applications can cause code execution [CVE-2010-2527, CVE-2010-2541].

Robert Swiecki of the Google Security Team reported several of these vulnerabilities. Marek Kasik reported one of the demo application vulnerabilities.

Impact:   A remote user can create a file that, when loaded by the target application, will execute arbitrary code on the target system.
Solution:   The vendor has issued a source code fix.

[Editor's note: All of the vulnerabilities except for CVE-2010-2541 are corrected in 2.4.1.]

Vendor URL:  www.freetype.org/ (Links to External Site)
Cause:   Access control error, Boundary error
Underlying OS:   Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Jul 30 2010 (Red Hat Issues Fix) FreeType 2 Font File Processing Errors Let Remote Users Execute Arbitrary Code   (bugzilla@redhat.com)
Red Hat has issued a fix for Red Hat Enterprise Linux 4 and 5.
Jul 30 2010 (Red Hat Issues Fix) FreeType 2 Font File Processing Errors Let Remote Users Execute Arbitrary Code   (bugzilla@redhat.com)
Red Hat has issued a fix for Red Hat Enterprise Linux 3.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC