SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Multimedia)  >   Adobe AIR Vendors:   Adobe Systems Incorporated
Adobe AIR Multiple Flaws Let Remote Users Execute Arbitary Code, Conduct Cross-Site Scripting Attacks, and Deny Service
SecurityTracker Alert ID:  1024086
SecurityTracker URL:  http://securitytracker.com/id/1024086
CVE Reference:   CVE-2008-4546, CVE-2009-3793, CVE-2010-2160, CVE-2010-2161, CVE-2010-2162, CVE-2010-2163, CVE-2010-2164, CVE-2010-2165, CVE-2010-2166, CVE-2010-2167, CVE-2010-2169, CVE-2010-2170   (Links to External Site)
Updated:  Jun 29 2010
Original Entry Date:  Jun 11 2010
Impact:   Denial of service via network, Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.5.3.9130 and prior versions
Description:   Multiple vulnerabilities were reported in Adobe AIR. A remote user can cause arbitrary code to be executed on the target user's system. A remote user can conduct cross-site scripting attacks. A remote user can cause denial of service conditions.

A remote user can create specially crafted content that, when loaded by the target user, will execute arbitrary code on the target system. The code will run with the privileges of the target user.

Various memory corruption, buffer overflows, use-after-free memory access, pointer errors, indexing errors, and memory exhaustion flaws permit arbitrary code execution [CVE-2009-3793, CVE-2010-2160, CVE-2010-2161, CVE-2010-2162, CVE-2010-2163, CVE-2010-2164, CVE-2010-2165, CVE-2010-2166, CVE-2010-2167, CVE-2010-2169, CVE-2010-2170, CVE-2010-2171, CVE-2010-2173, CVE-2010-2174, CVE-2010-2175, CVE-2010-2176, CVE-2010-2177, CVE-2010-2178, CVE-2010-2180, CVE-2010-2181, CVE-2010-2182, CVE-2010-2183, CVE-2010-2184, CVE-2010-2185, CVE-2010-2187, CVE-2010-2188].

A denial of service flaw may be able to be leveraged to execute arbitrary code [CVE-2010-2186].

A memory corruption flaw on VMware systems with VMware Tools enabled can allow code execution [CVE-2010-2189].

A denial of service flaw exists [CVE-2008-4546].

A URL parsing error can permit cross-site scripting attacks [CVE-2010-2179], affecting Firefox and Chrome browsers.

Will Dormann of CERT, Ralph Loader of Innaworks Development Limited, an anonymous researcher (via TippingPoint's Zero Day Initiative), Dionysus Blazakis (via TippingPoint's Zero Day Initiative), an anonymous researcher (via iDefense's Vulnerability Contributor Program), Damian Put (via TippingPoint's Zero Day Initiative), Megumi Yanagishita of Palo Alto Networks Inc., Bing Liu of Fortinet's FortiGuard Labs, Nicolas Joly of VUPEN Vulnerability Research Team, Manuel Caballero and Microsoft Vulnerability Research (MSVR), Tielei Wang from ICST-ERCIS (Engineering Research Center of Info Security, Institute of Computer Science & Technology, Peking University/China), Red Hat Security Response Team, Bo Qu of Palo Alto Networks, Ezio Anselmo Mazarim Fernandes, Haifei Li of Fortinet's FortiGuard Labs, and Tavis Ormandy of the Google Security Team reported these vulnerabilities.

Impact:   A remote user can create content that, when loaded by the target user, will execute arbitrary code on the target user's system.

A remote user can conduct cross-site scripting attacks.

A remote user can cause denial of service conditions.

Solution:   The vendor has issued a fix (2.0.2.12610).

The vendor's advisory is available at:

http://www.adobe.com/support/security/bulletins/apsb10-14.html

[Editor's note: On June 29, 2010, the vendor reported that this fix did not fully correct CVE-2010-2188.]

Vendor URL:  www.adobe.com/support/security/bulletins/apsb10-14.html (Links to External Site)
Cause:   Access control error, Boundary error, State error
Underlying OS:   Linux (Any), UNIX (OS X), Windows (Any)

Message History:   None.


 Source Message Contents

Date:  Fri, 11 Jun 2010 02:15:20 +0000
Subject:  Adobe AIR


http://www.adobe.com/support/security/bulletins/apsb10-14.html

CVE-2008-4546, CVE-2009-3793
CVE-2010-2160, CVE-2010-2161, CVE-2010-2162, CVE-2010-2163, CVE-2010-2164, 
CVE-2010-2165, CVE-2010-2166, CVE-2010-2167, CVE-2010-2169, CVE-2010-2170, 
CVE-2010-2171, CVE-2010-2172, CVE-2010-2173, CVE-2010-2174, CVE-2010-2175, 
CVE-2010-2176, CVE-2010-2177, CVE-2010-2178, CVE-2010-2179, CVE-2010-2180, 
CVE-2010-2181, CVE-2010-2182, CVE-2010-2183, CVE-2010-2184, CVE-2010-2185, 
CVE-2010-2186, CVE-2010-2187, CVE-2010-2188, CVE-2010-2189

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC