SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   Perl Vendors:   Wall, Larry
Perl Safe Module (Safe::reval and Safe::rdo) Can Be Bypassed
SecurityTracker Alert ID:  1024062
SecurityTracker URL:  http://securitytracker.com/id/1024062
CVE Reference:   CVE-2010-1168   (Links to External Site)
Date:  Jun 7 2010
Impact:   User access via local system
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 5.10.0 and prior
Description:   A vulnerability was reported in Perl. A local user can bypass certain safe module restrictions.

Implicitly called methods (e.g., DESTROY, AUTOLOAD) are not properly restricted by Safe::reval and Safe::rdo. A local user can run a specially crafted Perl script within a Safe compartment to execute those methods without restriction.

Safe.pm version 2.24 and prior versions are affected.

Nick Cleaton reported this vulnerability.

Impact:   A local user can bypass certain safe module restrictions.
Solution:   The vendor has issued a fix (Safe.pm v2.25).
Vendor URL:  cpan.org/ (Links to External Site)
Cause:   Access control error
Underlying OS:   Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Jun 7 2010 (Red Hat Issues Fix) Perl Safe Module (Safe::reval and Safe::rdo) Can Be Bypassed   (bugzilla@redhat.com)
Red Hat has issued a fix for Red Hat Enterprise Linux 3 and 4.
Jun 8 2010 (Red Hat Issues Fix) Perl Safe Module (Safe::reval and Safe::rdo) Can Be Bypassed   (bugzilla@redhat.com)
Red Hat has issued a fix for Red Hat Enterprise Linux 5.
Nov 28 2010 (Sun Issues Fix) Perl Safe Module (Safe::reval and Safe::rdo) Can Be Bypassed
Sun has issued a fix for Solaris 10.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC