SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   HP OpenView Vendors:   HP (Compaq)
HP OpenView Network Node Manager SNMP/MIB Bug Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1022360
SecurityTracker URL:  http://securitytracker.com/id/1022360
CVE Reference:   CVE-2009-1420   (Links to External Site)
Updated:  Jun 26 2009
Original Entry Date:  Jun 9 2009
Impact:   Denial of service via network, Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 7.51, 7.53
Description:   A vulnerability was reported in HP OpenView Network Node Manager. A remote user can execute arbitrary code on the target system.

On systems running running SNMP and MIB, a remote user can send specially crafted data to trigger a stack overflow in the rping application and execute arbitrary code on the target system or cause denial of service conditions on the target system. The code will run with the privileges of the target service.

The vendor was notified on May 19, 2008.

An anonymous reported this vulnerability via iDefense.

Impact:   A remote user can execute arbitrary code on the target system.

A remote user can cause denial of service conditions on the target system.

Solution:   The vendor has issued patches for OV NNM v7.53, available at:

http://support.openview.hp.com/selfsolve/patches

HP-UX (IA): NNM753CPTIPF_00002 or subsequent
HP-UX (PA): NNM753CPTHP_00002 or subsequent
Linux RedHatAS2.1: NNM753CPTLIN24_00002 or subsequent
Linux RedHat4AS-x86_64: NNM753CPTLIN26_00002 or subsequent
Solaris: NNM753CPTSOL_00002 or subsequent
Windows: NNM753CPTWIN_00002 or subsequent

The vendor's advisory is available at:

http://www13.itrc.hp.com/service/cki/docDisplay.do?docId=emr_na-c01754877

Vendor URL:  www13.itrc.hp.com/service/cki/docDisplay.do?docId=emr_na-c01754877 (Links to External Site)
Cause:   Boundary error
Underlying OS:   Linux (Any), UNIX (HP/UX), UNIX (Solaris - SunOS), Windows (Any)

Message History:   None.


 Source Message Contents

Date:  Tue, 9 Jun 2009 17:11:57 -0400
Subject:  HPSBMA02430 SSRT080094 rev.1 - HP OpenView Network Node Manager (OV NNM) Running SNMP and MIB, Remote Execution of Arbitrary Code, Denial of Service (DoS)


http://www13.itrc.hp.com/service/cki/docDisplay.do?docId=emr_na-c01754877

CVE-2009-1420
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC