SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   Ghostscript Vendors:   GNU [multiple authors]
Ghostscript Overflows in International Color Consortium Format Library Lets Users Execute Arbitrary Code
SecurityTracker Alert ID:  1021868
SecurityTracker URL:  http://securitytracker.com/id/1021868
CVE Reference:   CVE-2009-0583, CVE-2009-0584   (Links to External Site)
Date:  Mar 20 2009
Impact:   Execution of arbitrary code via local system, Execution of arbitrary code via network, User access via local system, User access via network

Version(s): 8.64
Description:   A vulnerability was reported in Ghostscript. A user can cause arbitrary code to be executed on the target user's system.

A user can create a specially crafted International Color Consortium (ICC) file. When the target user opens a specially crafted PostScript or PDF file containing embedded images, a buffer overflow may occur and arbitrary code may be executed with the privileges of the target user.

The vulnerability resides in 'icclib/icc.c'.

Impact:   A user can create a file that, when loaded by the target user, will execute arbitrary code on the target user's system.
Solution:   No solution was available at the time of this entry.
Vendor URL:  www.ghostscript.com/ (Links to External Site)
Cause:   Boundary error, Input validation error
Underlying OS:   Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Mar 20 2009 (Red Hat Issues Revised Fix) Ghostscript Overflows in International Color Consortium Format Library Lets Users Execute Arbitrary Code   (bugzilla@redhat.com)
Red Hat has released a fix for Red Hat Enterprise Linux 3, 4, and 5.
Jun 26 2009 (Sun Issues Fix) Ghostscript Overflows in International Color Consortium Format Library Lets Users Execute Arbitrary Code
Sun has issued a fix for Solaris 10 and OpenSolaris.



 Source Message Contents

Date:  Thu, 19 Mar 2009 22:30:10 -0500
Subject:  Ghostscript


https://bugzilla.redhat.com/show_bug.cgi?id=487742
https://bugzilla.redhat.com/show_bug.cgi?id=487744

CVE-2009-0583
CVE-2009-0584
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC