SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Security)  >   Symantec Data Loss Prevention Vendors:   Symantec
Symantec Data Loss Prevention Buffer Overflow in Autonomy KeyView Module Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1021856
SecurityTracker URL:  http://securitytracker.com/id/1021856
CVE Reference:   CVE-2008-4564   (Links to External Site)
Date:  Mar 17 2009
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   A vulnerability was reported in Symantec Data Loss Prevention. A remote user can execute arbitrary code on the target system.

A remote user can send specially crafted data to trigger a buffer overflow in the 3rd party Autonomy KeyView module and execute arbitrary code on the target system. The code will run with the privileges of the target service.

The following models are affected:

Symantec Data Loss Prevention Detection Servers/Enforce version 7.x and 8.0
Symantec Data Loss Prevention Endpoint Agents version 8.0 and 8.1.x
Symantec Data Loss Prevention Detection Servers/Enforce for Windows version 8.1.x
Symantec Data Loss Prevention Detection Servers/Enforce for Linux version 8.1.x

Symantec Data Loss Prevention version 7.x Endpoint Agents are not affected.

An anonymous researcher reported this vulnerability via iDefense.

Impact:   A remote user can execute arbitrary code on the target system.
Solution:   The vendor has issued the following fixes.

Symantec Data Loss Prevention Detection Servers/Enforce 7.x: Hotfix_7.2.0.37

Symantec Data Loss Prevention Detection Servers/Enforce 8.0: Hotfix_8.0.10.38_1

Symantec Data Loss Prevention Endpoint Agents 8.0: Hotfix_8.0.10.38_2

Symantec Data Loss Prevention Detection Servers/Enforce for Windows 8.1.x: Hotfix_8.1.5.15_Windows

Symantec Data Loss Prevention Detection Servers/Enforce for Linux 8.1.x: Hotfix_8.1.5.15_Linux

Symantec Data Loss Prevention Endpoint Agents 8.1.x: Hotfix_8.1.6.2

The vendor's advisory is available at:

http://securityresponse.symantec.com/avcenter/security/Content/2009.03.17a.html

Vendor URL:  securityresponse.symantec.com/avcenter/security/Content/2009.03.17a.html (Links to External Site)
Cause:   Boundary error
Underlying OS:   Linux (Red Hat Enterprise), Windows (2003), Windows (Vista), Windows (XP)

Message History:   None.


 Source Message Contents

Date:  Tue, 17 Mar 2009 14:22:06 -0500
Subject:  http://securityresponse.symantec.com/avcenter/security/Content/2009.03.17a.html


CVE-2008-4564
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC