SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Security)  >   pam_krb5 Vendors:   [Multiple Authors/Vendors]
pam-krb5 Lets Local Users Gain Elevated Privileges
SecurityTracker Alert ID:  1021711
SecurityTracker URL:  http://securitytracker.com/id/1021711
CVE Reference:   CVE-2009-0360, CVE-2009-0361   (Links to External Site)
Date:  Feb 12 2009
Impact:   Modification of system information, Modification of user information, Root access via local system, User access via local system
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 3.13
Description:   Two vulnerabilities were reported in pam-krb5. A local user can obtain elevated privileges on the target system.

pam-krb5 does not use the correct API for initializing the Kerberos libraries in a set user id (setuid) environment when linked with MIT Kerberos [CVE-2009-0360]. As a result, a local user can bypass authentication in setuid applications that use PAM for authentication. The software is not affected when linked with Heimdal Kerberos.

A local user can cause pam-krb5 to overwrite and chown the file specified by the KRB5CCNAME environment variable when an application uses pam_setcred with PAM_REINITIALIZE_CREDS or PAM_REFRESH_CREDS to refresh existing user credentials [CVE-2009-0361].

The Russ Allbery version of pam-krb5 is affected.

Impact:   A local user can obtain elevated privileges on the target system.

A local user can overwrite and gain ownership of files on the target system.

Solution:   The vendor has issued a fixed version (3.13).

The vendor's advisory is available at:

http://www.eyrie.org/~eagle/software/pam-krb5/security/2009-02-11.html

Vendor URL:  www.eyrie.org/~eagle/software/pam-krb5/security/2009-02-11.html (Links to External Site)
Cause:   Access control error
Underlying OS:   Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Feb 13 2009 (Sun Issues Advisory) pam-krb5 Lets Local Users Gain Elevated Privileges
Sun has issued an advisory for Solaris 9 and 10 and OpenSolaris.
Apr 7 2009 (HP Issues Fix for HP-UX) pam-krb5 Lets Local Users Gain Elevated Privileges
HP has issued a fix for HP-UX 11.11, 11.23, and 11.31.



 Source Message Contents

Date:  Thu, 12 Feb 2009 07:23:43 -0500
Subject:  pam-krb5


http://www.eyrie.org/~eagle/software/pam-krb5/security/2009-02-11.html

CVE-2009-0360, CVE-2009-0361
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC