SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (E-mail Server)  >   IMAP Toolkit (uw-imap) Vendors:   University of Washington
uw-imap Client Library Bug Lets Remote Users Deny Service
SecurityTracker Alert ID:  1021485
SecurityTracker URL:  http://securitytracker.com/id/1021485
CVE Reference:   CVE-2008-5514   (Links to External Site)
Date:  Dec 22 2008
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to imap-2007e
Description:   A vulnerability was reported in the IMAP Toolkit (uw-imap) client library. A remote user can cause denial of service conditions against applications that use the client library.

A remote user can send e-mail with specially crafted e-mail addresses to trigger a buffer overflow in the RFC822BUFFER routines and cause the target application that is using the client library to crash.

The php imap module is affected.

The imap daemon is not affected.

Impact:   A remote user can cause the target application using the client library to crash.
Solution:   The vendor has issued a fixed version (imap-2007e).

The vendor's advisory is available at:

http://www.washington.edu/imap/documentation/RELNOTES.html

Cause:   Boundary error
Underlying OS:   Linux (Any), UNIX (Any)

Message History:   None.


 Source Message Contents

Date:  Mon, 22 Dec 2008 10:02:15 -0500
Subject:  UW-IMAP


http://www.washington.edu/imap/documentation/RELNOTES.html

imap-2007e is a maintenance release, consisting primarily of bugfixes to
problems discovered in the release that affected a small number of users
plus a security fix for users of the RFC822BUFFER routines.

CVE-2008-5514
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC