SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   TIBCO SmartSockets Vendors:   TIBCO Software
TIBCO SmartSockets Untrusted Pointer and Pointer Offset Values and Buffer Overflows Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1019193
SecurityTracker URL:  http://securitytracker.com/id/1019193
CVE Reference:   CVE-2007-5655, CVE-2007-5656, CVE-2007-5657, CVE-2007-5658   (Links to External Site)
Date:  Jan 15 2008
Impact:   Execution of arbitrary code via network, Root access via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 6.8.1
Description:   Several vulnerabilities were reported in TIBCO SmartSockets. A remote user can execute arbitrary code on the target system. TIBCO RTworks and TIBCO Enterprise Message Service are also affected.

A remote user can send specially crafted data to execute arbitrary code on the target system. The code will run with the privileges of the target service.

The software accepts untrusted pointer and pointer offset values. The software also contains heap overflows.

The following SmartSockets components are affected:

TIBCO SmartSockets Server (rtserver)
TIBCO SmartSockets Cache (scache)
TIBCO SmartSockets Gateway (rtgateway)
TIBCO SmartSockets LiveWeb (rtweb)
TIBCO SmartSockets client libraries (rtipc, rtmsg, rtutil)
TIBCO SmartMQ Server (mqserver)

TIBCO SmartSockets Product Family (RTworks) versions prior to 4.0.4 are also affected.

TIBCO Enterprise Message Service (EMS) versions 4.0.0 through 4.4.1 are also affected.

The vendor was notified on October 23, 2007.

McSlibin reported some of these vulnerabilities via iDefense. Sean Larsson of VeriSign iDefense Labs reported some of these vulnerabilities.

Impact:   A remote user can execute arbitrary code on the target system.
Solution:   The vendor has issued a fixed versions:

SmartSockets: 6.8.1
SmartSockets Product Family Modules, formerly RTworks: 4.0.4
Enterprise Message Service: 4.4.2

The TIBCO advisories are available at:

http://www.tibco.com/resources/mk/smartsockets_security_advisory_20080115.txt
http://www.tibco.com/resources/mk/sspfm_security_advisory_20080115.txt
http://www.tibco.com/resources/mk/ems_security_advisory_20080115.txt

Vendor URL:  www.tibco.com/resources/mk/smartsockets_security_advisory_20080115.txt (Links to External Site)
Cause:   Access control error, Boundary error
Underlying OS:   UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Date:  Tue, 15 Jan 2008 14:01:22 -0500
Subject:  iDefense Security Advisory 01.15.08: TIBCO SmartSockets RTserver

iDefense Security Advisory 01.15.08
http://labs.idefense.com/intelligence/vulnerabilities/
Jan 15, 2008

I. BACKGROUND

TIBCO SmartSockets is a message passing framework used to transport
messages over disparate channels. The RTserver is the server component
of the framework. More information can be found on the vendor's web
site at the following URL.

http://www.tibco.com/software/messaging/smartsockets/

II. DESCRIPTION

Remote exploitation of a heap overflow vulnerability in TIBCO Software
Inc.'s SmartSockets RTserver may allow an attacker to crash the service
or execute arbitrary code with SYSTEM privileges.

A heap overflow vulnerability exists within the code responsible for
processing requests. Two distinct values from the request are used for
the allocation size and the amount of data copied. Since both values
are attacker controlled, this can lead to a heap overflow, potentially
resulting in the execution of arbitrary code.

III. ANALYSIS

Exploitation allows an attacker to execute arbitrary code with SYSTEM
privileges. Unsuccessful attempts will likely crash the RTserver. The
service does not restart, which makes repeated exploitation attempts
more difficult.

The RTserver is the core component of the SmartSockets framework.
Without it, applications will be unable to pass messages.

IV. DETECTION

iDefense has confirmed the existence of this vulnerability in TIBCO
SmartSockets version 6.8.0. Previous versions may also be affected.

V. WORKAROUND

iDefense is currently unaware of any workarounds for this issue.

VI. VENDOR RESPONSE

TIBCO has addressed this vulnerability by releasing new versions of
their software. For more information, consult their advisory at the
following URL.

http://www.tibco.com/mk/advisory.jsp

VII. CVE INFORMATION

The Common Vulnerabilities and Exposures (CVE) project has assigned the
name CVE-2007-5658 to this issue. This is a candidate for inclusion in
the CVE list (http://cve.mitre.org/), which standardizes names for
security problems.

VIII. DISCLOSURE TIMELINE

10/23/2007  Initial vendor notification
12/04/2007  Second vendor notification
12/05/2007  Initial vendor response
01/15/2008  Coordinated public disclosure

IX. CREDIT

This vulnerability was reported to VeriSign iDefense by McSlibin.

Get paid for vulnerability research
http://labs.idefense.com/methodology/vulnerability/vcp.php

Free tools, research and upcoming events
http://labs.idefense.com/

X. LEGAL NOTICES

Copyright  2008 iDefense, Inc.

Permission is granted for the redistribution of this alert
electronically. It may not be edited in any way without the express
written consent of iDefense. If you wish to reprint the whole or any
part of this alert in any other medium other than electronically,
please e-mail customerservice@idefense.com for permission.

Disclaimer: The information in the advisory is believed to be accurate
at the time of publishing based on currently available information. Use
of the information constitutes acceptance for use in an AS IS condition.
 There are no warranties with regard to this information. Neither the
author nor the publisher accepts any liability for any direct,
indirect, or consequential loss or damage arising from use of, or
reliance on, this information.
_______________________________________________
To unsubscribe, go here:
http://www.idefense.com/mailman/listinfo/idlabs-advisories


 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC