SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   OpenPegasus Vendors:   Open Group, The
OpenPegasus Stack Overflow in PAM Authentication Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1019159
SecurityTracker URL:  http://securitytracker.com/id/1019159
CVE Reference:   CVE-2008-0003   (Links to External Site)
Date:  Jan 7 2008
Impact:   Execution of arbitrary code via network, Root access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 2.7 and prior versions
Description:   A vulnerability was reported in OpenPegasus. A remote user can execute arbitrary code on the target system.

A remote user can send specially crafted data to trigger a stack overflow in the PAM authentication code and execute arbitrary code on the target system. The code will run with root privileges.

The vulnerability resides in PAMBasicAuthenticator::PAMCallback().

Impact:   A remote user can execute arbitrary code on the target system with root privileges.
Solution:   The vendor has issued a source code fix, available via CVS.

No vendor advisory was available at the time of this entry.

Vendor URL:  www.openpegasus.org/ (Links to External Site)
Cause:   Boundary error
Underlying OS:   Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Jan 7 2008 (Red Hat Issues Fix) OpenPegasus Stack Overflow in PAM Authentication Lets Remote Users Execute Arbitrary Code   (bugzilla@redhat.com)
Red Hat has released a fix for Red Hat Enterprise Linux 4 and 5.
Feb 21 2008 (IBM Issues Fix for AIX) OpenPegasus Stack Overflow in PAM Authentication Lets Remote Users Execute Arbitrary Code
IBM has issued a fix for AIX 5.2, 5.3, and 6.1.
Apr 16 2008 (VMware Issues Fix for ESX Server) OpenPegasus Stack Overflow in PAM Authentication Lets Remote Users Execute Arbitrary Code   (security-announce@lists.vmware.com)
VMware issued a fix for VMware ESX 3.0.1, 3.0.2, and 3.5.
Apr 30 2008 (HP Issues Fix for WBEM Services) OpenPegasus Stack Overflow in PAM Authentication Lets Remote Users Execute Arbitrary Code
HP has issued a fix for HP WBEM Services.



 Source Message Contents

Date:  Mon, 7 Jan 2008 14:52:21 -0500
Subject:  OpenPegasus


Red Hat says:

During a security audit, a stack buffer overflow flaw was found in the PAM
authentication code in the OpenPegasus CIM management server. An
unauthenticated remote user could trigger this flaw and potentially execute
arbitrary code with root privileges. (CVE-2008-0003)




 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC