SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   Microsoft Office Vendors:   Microsoft
Microsoft Office Excel Buffer Overflow Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1017584
SecurityTracker URL:  http://securitytracker.com/id/1017584
CVE Reference:   CVE-2007-0671   (Links to External Site)
Updated:  Feb 13 2007
Original Entry Date:  Feb 3 2007
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 2000, XP, 2003, 2004 for Mac, 2004 v. X for Mac
Description:   A vulnerability was reported in Microsoft Excel. A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can create an Excel file with a specially crafted record that, when loaded by the target user, will trigger a buffer overflow and execute arbitrary code on the target system. The code will run with the privileges of the target user.

The following Office versions are affected:

Microsoft Office 2000, Microsoft Office XP, Microsoft Office 2003, Microsoft Office 2004 for Mac, and Microsoft Office 2004 v. X for Mac.

Microsoft indicates that the vulnerability is currently being exploited in limited situations via Microsoft Excel files.

Impact:   A remote user can create a file that, when loaded by the target user, will execute arbitrary code on the target user's system.
Solution:   The vendor has issued the following fixes:

Microsoft Office 2000 Service Pack 3:

http://www.microsoft.com/downloads/details.aspx?familyid=20E089E7-7DD3-44A4-ABFE-6D8C27721683

Microsoft Office XP Service Pack 3:

http://www.microsoft.com/downloads/details.aspx?FamilyId=C54B1FDA-1237-48F7-AD19-F0830EE0E8FF

Microsoft Office 2003 Service Pack 2:

http://www.microsoft.com/downloads/details.aspx?FamilyId=BB0973E7-275D-4491-9BA1-91EAEA84EEFD

Microsoft Project 2000 Service Release 1:

http://www.microsoft.com/downloads/details.aspx?FamilyId=3DF54B5C-CB82-4A99-9B90-EDAB38AD6310

Microsoft Project 2002 Service Pack 1:

http://www.microsoft.com/downloads/details.aspx?FamilyId=419191DC-01B8-4E2A-BA5B-71BF3066C169

Microsoft Visio 2002 Service Pack 2:

http://www.microsoft.com/downloads/details.aspx?FamilyId=F50A5111-0926-4221-96DF-18294230ED1E

Microsoft Office 2004 for Mac:

http://www.microsoft.com/mac/

The Microsoft advisory is available at:

http://www.microsoft.com/technet/security/bulletin/ms07-015.mspx

The original Microsoft advisory is available at:

http://www.microsoft.com/technet/security/advisory/932553.mspx

Vendor URL:  www.microsoft.com/technet/security/bulletin/ms07-015.mspx (Links to External Site)
Cause:   Boundary error
Underlying OS:  

Message History:   None.


 Source Message Contents

Date:  Fri, 2 Feb 2007 20:46:57 -0500
Subject:  Vulnerability in Microsoft Office Could Allow Remote Code Execution


http://www.microsoft.com/technet/security/advisory/932553.mspx

CVE-2007-0671
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC