Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   


Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker

Category:   Application (Generic)  >   Wireshark Vendors:
Wireshark Bugs in TCP, HTTP, IEEE 802.11, and LLT Dissectors Let Remote Users Deny Service
SecurityTracker Alert ID:  1017581
SecurityTracker URL:
CVE Reference:   CVE-2007-0456, CVE-2007-0457, CVE-2007-0458, CVE-2007-0459   (Links to External Site)
Date:  Feb 1 2007
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 0.10.14 - 0.99.4
Description:   A vulnerability was reported in Wireshark. A remote user can cause the application to crash.

A remote user can send specially crafted packets that, when processed by the target application, will cause the application to hang or crash.

The TCP dissector is affected when reassembling HTTP packets (versions 0.99.2 and later).

The HTTP dissector is affected (0.99.3, 0.99.4).

The IEEE 802.11 dissector is affected (0.10.14 to 0.99.4).

The LLT dissector is affected (0.99.3, 0.99.4).

A specially crafted packet trace file can also trigger these flaws.

Impact:   A remote user can cause the target application to crash.
Solution:   The vendor has issued a fixed version (0.99.5).

The Wireshark advisory is available at:

Vendor URL: (Links to External Site)
Cause:   Not specified
Underlying OS:   Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Mar 14 2007 (Red Hat Issues Fix) Wireshark Bugs in TCP, HTTP, IEEE 802.11, and LLT Dissectors Let Remote Users Deny Service   (
Red Hat has released a fix for Red Hat Enterprise Linux 2.1, 3, 4, and 5.

 Source Message Contents

[Original Message Not Available for Viewing]

Go to the Top of This SecurityTracker Archive Page

Home   |    View Topics   |    Search   |    Contact Us

Copyright 2015, LLC