SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   Adobe Acrobat/Reader Vendors:   Adobe Systems Incorporated
Adobe Acrobat Reader Plugin Bugs Let Remote Users Deny Service, Conduct Cross-Site Scripting Attacks, and Execute Arbitrary Code
SecurityTracker Alert ID:  1017469
SecurityTracker URL:  http://securitytracker.com/id/1017469
CVE Reference:   CVE-2007-0044, CVE-2007-0045, CVE-2007-0046, CVE-2007-0047, CVE-2007-0048   (Links to External Site)
Updated:  Oct 13 2009
Original Entry Date:  Jan 4 2007
Impact:   Disclosure of authentication information, Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 7.0.8 and prior versions; CVE-2007-0045 and CVE-2007-0048 affected in 9.1.3 and prior versions; also 7.1 prior to 7.1.4, 8.1 prior to 8.1.7
Description:   Several vulnerabilities were reported in Adobe Acrobat. A remote user can cause arbitrary code to be executed on the target user's system. A remote user can conduct cross-site scripting attacks. A remote user can cause denial of service conditions.

The Adobe Reader plugins for Microsoft Internet Explorer, Mozilla Firefox, and Opera browsers are affected. Adobe Acrobat Standard, Acrobat Professional, Acrobat Elements, and Adobe Acrobat 3D are also affected when used with certain browsers.

A remote user can create a URL for a PDF file that, when loaded by the target user, will trigger a double-free error and execute arbitrary code on the target user's system. Firefox is affected.

A demonstration exploit URL is provided:

http://[target]/file.pdf#FDF=javascript:document.write('jjjjj...');

A remote user can create a URL for a PDF file that, when loaded by the target user, will cause denial of service conditions on the target user's system as the plugin allocates excessive memory. Internet Explorer is affected.

A demonstration exploit URL is provided:

http://[target]/file.pdf#####...

A remote user can create a specially crafted URL for a PDF file that, when loaded by a target user, will cause arbitrary scripting code to be executed by the target user's Firefox browser. The code will originate from the targegt site hosting the PDF file and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

A demonstration exploit URL is provided:

http://[target]/file.pdf#FDF=javascript:alert('Test Alert')

A remote user can also exploit this flaw to access files with the following type of URL:

http://[target]/file.pdf#FDF=javascript:document.location= 'file://C:/winnt/notepad.exe'

A remote user can create a specially crafted URL for a PDF file that, when loaded by a target user, can conduct cross-site request forgery attacks. Internet Explorer and Opera are affected.

A demonstration exploit URL is provided:

http://[target]/file.pdf#FDF=http://[victim]/index.html?param=...

The vendor was notified on October 15, 2006.

The original advisory is available at:

http://www.wisec.it/vulns.php?page=9

The vulnerabilities were documented in a presentation given at the 23rd CCC Congress. The presentation is available at:

http://www.wisec.it/rdr.php?fn=Projects/1158-Subverting_Ajax.pdf

Stefano Di Paola discovered these vulnerabilities.

On October 13, 2009, Michael Schmidt of Compass Security reported that the plugin used with the Google Chrome and Opera browsers is also affected by CVE-2007-0045 and CVE-2007-0048 cross-site scripting vulnerabilities.

Impact:   A remote user can create a URL that, when loaded by the target user, will execute arbitrary code on the target user's system.

A remote user can create a URL that, when loaded by the target user, will cause denial of service conditions on the target user's system.

A remote user can access the target user's cookies (including authentication cookies), if any, associated with a target site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

Solution:   The vendor has issued fixed versions of Adobe Reader (7.0.9, 8.0.0).

The Adobe Advisory is available at:

http://www.adobe.com/support/security/bulletins/apsb07-01.html

The vendor has described workarounds for website operators to prevent the cross-site scripting vulnerability (CVE-2007-0045) from the server side, available at:

Some http://www.adobe.com/support/security/advisories/apsa07-02.html

On October 13, 2009, the vendor issued an additional fix (7.1.4, 8.1.7, 9.2) for CVE-2007-0045 and CVE-2007-0048, as reported in APSB09-15:

http://www.adobe.com/support/security/bulletins/apsb09-15.html

Vendor URL:  www.adobe.com/support/security/bulletins/apsb07-01.html (Links to External Site)
Cause:   Boundary error, Input validation error
Underlying OS:   Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Jan 11 2007 (Red Hat Issues Fix) Adobe Acrobat Reader Plugin Bugs Let Remote Users Deny Service, Conduct Cross-Site Scripting Attacks, and Execute Arbitrary Code   (bugzilla@redhat.com)
Red Hat has released a fix for Red Hat Enterprise Linux Extras 4.
Jan 22 2007 (Red Hat Issues Fix for Extras) Adobe Acrobat Reader Plugin Bugs Let Remote Users Deny Service, Conduct Cross-Site Scripting Attacks, and Execute Arbitrary Code   (bugzilla@redhat.com)
Red Hat has released a fix for Red Hat Enterprise Linux Extras 3.
Mar 16 2007 (Sun Describes Workaround) Adobe Acrobat Reader Plugin Bugs Let Remote Users Deny Service, Conduct Cross-Site Scripting Attacks, and Execute Arbitrary Code
Sun has described a workaround.



 Source Message Contents

Date:  Wed, 3 Jan 2007 23:46:44 -0500
Subject:  Adobe Acrobat Reader Plugin - Multiple Vulnerabilities


http://www.wisec.it/vulns.php?page=9

CVE-2007-0045
CVE-2007-0046
CVE-2007-0047
CVE-2007-0048
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC