Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   


Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker

Category:   Application (Forum/Board/Portal)  >   PNphpBB Vendors:
PNphpBB Include File Bug in 'includes/functions_admin.php' Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1016912
SecurityTracker URL:
CVE Reference:   CVE-2006-4968   (Links to External Site)
Updated:  Jun 3 2008
Original Entry Date:  Sep 22 2006
Impact:   Execution of arbitrary code via network, User access via network
Exploit Included:  Yes  
Version(s): 1.2g; possibly prior versions
Description:   A vulnerability was reported in PNphpBB. A remote user can include and execute arbitrary code on the target system.

The 'includes/functions_admin.php' script does not properly validate user-supplied input in the 'phpbb_root_path' parameter. A remote user can supply a specially crafted URL to cause the target system to include and execute arbitrary PHP code from a remote location. The PHP code, including operating system commands, will run with the privileges of the target web service.
isn't initialize

A demonstration exploit URL is provided:


AzzCoder reported this vulnerability.

Impact:   A remote user can execute arbitrary PHP code and operating system commands on the target system with the privileges of the target web service.
Solution:   Version 1.2i is not affected.
Vendor URL: (Links to External Site)
Cause:   Input validation error, State error
Underlying OS:   Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.

 Source Message Contents

Date:  Mon, 18 Sep 2006 03:28:06 +0000
Subject:  AzzCoder => PNphpBB (Latest) Remote File Include


Vulnerable File: includes/functions_admin.php

Vulnerable Code:

//The phpbb_root_path isn't initialize

include_once( $phpbb_root_path . 'includes/functions.' . $phpEx );

Method To Use:[pn_phpbb]/includes/functions_admin.php?phpbb_root_path=

How To Fix:

Add this code before the include

if ( !defined('IN_PHPBB') )


   die("Hacking attempt");



Go to the Top of This SecurityTracker Archive Page

Home   |    View Topics   |    Search   |    Contact Us

Copyright 2015, LLC