SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Multimedia)  >   QuickTime Vendors:   Apple Computer
QuickTime Overflows in Processing H.264, QuickTime, FLC, FlashPix and SGI Files Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1016830
SecurityTracker URL:  http://securitytracker.com/id/1016830
CVE Reference:   CVE-2006-4381, CVE-2006-4382, CVE-2006-4384, CVE-2006-4385, CVE-2006-4386, CVE-2006-4388, CVE-2006-4389   (Links to External Site)
Date:  Sep 12 2006
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 7.1.3
Description:   Several vulnerabilities were reported in QuickTime. A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can create a specially crafted file that, when loaded by the target user, will cause arbitrary code to be executed on the target system. The code will run with the privileges of the target user.

A specially crafted H.264 movie can cause arbitrary code execution [CVE-2006-4381, CVE-2006-4386]. Apple credits Sowhat of Nevis Labs, Mike Price of McAfee AVERT Labs, and Piotr Bania for reporting this vulnerability.

A specially crafted QuickTime movie can cause arbitrary code execution [CVE-2006-4382]. Apple credits Mike Price of McAfee AVERT Labs with reporting this vulnerability.

A specially crafted FLC movie can cause arbitrary code execution [CVE-2006-4384]. Apple credits Ruben Santamarta of reversemode.com and iDEFENSE and Mike Price of McAfee AVERT Labs with reporting this vulnerability.

The iDEFENSE advisory is available at:

http://www.idefense.com/intelligence/vulnerabilities/display.php?id=413

A specially crafted FlashPix can cause arbitrary code execution [CVE-2006-4388, CVE-2006-4389]. Apple credits Mike Price of McAfee AVERT Labs with reporting these vulnerabilities.

A specially crafted SGI image can cause arbitrary code execution [CVE-2006-4385]. Apple credits Mike Price of McAfee AVERT Labs with reporting this vulnerability.

Impact:   A remote user can create a media file that, when loaded by the target user, will execute arbitrary code on the target user's system.
Solution:   Apple has issued a fixed version (7.1.3E), available via Software Update preferences or from Apple Downloads at:

http://www.apple.com/support/downloads/

Vendor URL:  docs.info.apple.com/article.html?artnum=304357 (Links to External Site)
Cause:   Boundary error
Underlying OS:   UNIX (OS X), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC