Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   


Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker

Category:   Application (Forum/Board/Portal)  >   BinGoPHP NEWS Vendors:
BinGoPHP NEWS Include File Flaw in 'bnrep' Parameter Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1016811
SecurityTracker URL:
CVE Reference:   CVE-2006-4648, CVE-2006-4649   (Links to External Site)
Updated:  Jan 8 2007
Original Entry Date:  Sep 8 2006
Impact:   Execution of arbitrary code via network, User access via network
Exploit Included:  Yes  
Version(s): 3.01 and prior versions
Description:   A vulnerability was reported in BinGoPHP NEWS. A remote user can include and execute arbitrary code on the target system.

The software does not properly validate user-supplied input in the 'bnrep' parameter. A remote user can supply a specially crafted URL to cause the target system to include and execute arbitrary PHP code from a remote location. The PHP code, including operating system commands, will run with the privileges of the target web service.

Some demonstration exploit URLs are provided:


Kw3[R]Ln [ Romanian Security Team ] discovered this vulnerability.

Impact:   A remote user can execute arbitrary PHP code and operating system commands on the target system with the privileges of the target web service.
Solution:   No solution was available at the time of this entry.
Vendor URL: (Links to External Site)
Cause:   Input validation error, State error
Underlying OS:   Linux (Any), UNIX (Any)

Message History:   None.

 Source Message Contents

Date:  7 Sep 2006 08:59:57 -0000
Subject:  BinGoPHP News <= 3.01 [bnrep] Remote File Include Vulnerability

BinGoPHP News <= 3.01 [bnrep] Remote File Include Vulnerability

Discovered By Kw3[R]Ln [ Romanian Security Team ] : hTTp:// :
Remote : Yes
Critical Level : Dangerous

Affected software description :
Application : BinGoPHP News
version : 3.01

Variable $phpbb_root_path not sanitized.When register_globals=on an attacker ca
n exploit this vulnerability with a simple php injection script.


Solution :
declare variabel $bnrep


# Special greetz to my good friend [Oo]
# To all members of #h4cky0u and RST [ hTTp:// ]



Nick: Kw3rLn
E-mail: ciriboflacs[at]YaHoo[dot]Com
Homepage: hTTp://RST-CREW.NET

-------------------------------- [ EOF] ----------------------------------


Go to the Top of This SecurityTracker Archive Page

Home   |    View Topics   |    Search   |    Contact Us

Copyright 2015, LLC