SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Database)  >   PostgreSQL Vendors:   postgresql.org
PostgreSQL Encoding Processes May Let Remote Users Inject SQL Commands
SecurityTracker Alert ID:  1016142
SecurityTracker URL:  http://securitytracker.com/id/1016142
CVE Reference:   CVE-2006-2313, CVE-2006-2314   (Links to External Site)
Date:  May 23 2006
Impact:   Disclosure of system information, Disclosure of user information, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 8.1.4
Description:   A vulnerability was reported in PostgreSQL in the processing of encoded strings. A remote user may be able to inject SQL commands.

The software does not properly validate user-supplied input. A remote user can supply specially crafted, invalidly-encoded multibyte characters to bypass string-escaping methods and potentially execute SQL commands on the underlying database [CVE-2006-2313]. Versions prior to 8.1.4, 8.0.8, 7.4.13, and 7.3.15 are affected.

When an application escapes ASCII single quote characters "'" by coverting the character to the "\'" string is unsafe when operating in multibyte encodings (e.g., SJIS, BIG5, GBK, GB18030, UHC) that allow 0x5c (ASCII code for backslash) as the trailing byte of a multibyte character [CVE-2006-2314]. A remote user may be able to exploit an application that uses this conversion method to inject SQL commands.

The specific impact depends on the applications that process the user-supplied input.

The vendor's technical description of the vulnerability is available at:

http://www.postgresql.org/docs/techdocs.50

Impact:   A remote user may be able to execute SQL commands on the underlying database. The specific impact depends on the application that accepts user-supplied input.
Solution:   The vendor has issued a fixed version (8.1.4), available at:

http://www.postgresql.org/download

Vendor URL:  www.postgresql.org/docs/techdocs.52 (Links to External Site)
Cause:   Input validation error
Underlying OS:   Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
May 23 2006 (Red Hat Issues Fix) PostgreSQL Encoding Processes May Let Remote Users Inject SQL Commands   (bugzilla@redhat.com)
Red Hat has released a fix for Red Hat Enterprise Linux 3 and 4.



 Source Message Contents

Date:  Tue, 23 May 2006 16:52:02 -0400
Subject:  PostgreSQL vulnerabilities


http://www.postgresql.org/docs/techdocs.52

CVE-2006-2313
CVE-2006-2314
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC