SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Web Server/CGI)  >   Oracle WebLogic Vendors:   BEA Systems
WebLogic Server Records Failed User Passwords in the Server Log File
SecurityTracker Alert ID:  1016098
SecurityTracker URL:  http://securitytracker.com/id/1016098
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  May 15 2006
Impact:   Disclosure of authentication information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 6.1 SP7, 7.0 SP6, 8.1 SP5, 9.0; and prior service packs
Description:   A vulnerability was reported in WebLogic Server. A local user may be able to obtain user password information.

The WebLogic Server HTTP handlers record the username and password in the WebLogic Server log when an authentication failure occurs. A local user with access to the log file can view supplied passwords.

Impact:   A local user with access to the log file can view user-supplied password values for failed login attempts.
Solution:   The vendor has issued the following solution [quoted]:

WebLogic Server 9.0

1. Install the 9.0 GA Combo patch from support.bea.com by requesting Bug ID CR239280.
2. Install the patch from::
ftp://ftpna.bea.com/pub/releases/security/CR247655_900.jar
3. Place the jar for the patch at the end of the PATCH_CLASSPATH.

BEA Systems also recommends an upgrade to version 9.1 to resolve this problem.

WebLogic Server and WebLogic Express version 8.1

1. Upgrade to WebLogic Server and WebLogic Express 8.1 Service Pack 5.
2. Install the patch from::
ftp://ftpna.beasys.com/pub/releases/security/CR247655_810sp5.jar
3. Place the jar for the patch at the end of the PATCH_CLASSPATH.

WebLogic Server 8.1 Service Pack 6 will include the functionality in this patch.

WebLogic Server and WebLogic Express version 7.0

* Upgrade to service pack 7.

WebLogic Server and WebLogic Express version 6.1

1. Upgrade to WebLogic Server and WebLogic Express 6.1 Service Pack 7.
2. Install the patch from::
ftp://ftpna.beasys.com/pub/releases/security/CR247655_610sp7.jar
3. Place the jar for the patch at the end of the PATCH_CLASSPATH.

The vendor's advisory is available at:

http://dev2dev.bea.com/pub/advisory/189

Vendor URL:  dev2dev.bea.com/pub/advisory/189 (Links to External Site)
Cause:   Access control error
Underlying OS:   Linux (Red Hat Enterprise), Linux (SuSE), UNIX (AIX), UNIX (HP/UX), UNIX (Solaris - SunOS), Windows (NT), Windows (2000), Windows (2003)

Message History:   None.


 Source Message Contents

Date:  Mon, 15 May 2006 16:33:26 -0400
Subject:  BEA WebLogic vulnerabilities


WebLogic Server 6.1, 7.0, 8.1, 9.0, 9.1
  
Security Advisory (BEA06-81.02, BEA06-87.01, BEA06-114.01, BEA06-120.01, 
BEA06-121.00, BEA06-124.00, BEA06-125.00, BEA06-126.00, BEA06-127.00, 
BEA06-128.00, BEA06-129.00, BEA06-130.00, BEA06-131.00, BEA06-132.00, 
BEA06-133.00)
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC