Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   


Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker

Category:   Application (Forum/Board/Portal)  >   Text Rider Vendors:   Ahmad
Text Rider Lets Remote Users Obtain Authentication Information
SecurityTracker Alert ID:  1015533
SecurityTracker URL:
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Jan 24 2006
Impact:   Disclosure of authentication information, Disclosure of user information
Exploit Included:  Yes  
Version(s): 2.4
Description:   Aliaksandr Hartsuyeu of eVuln reported a vulnerability in Text Rider. A remote user can obtain authentication information.

In the default configuration, the software does not protect access to the 'data/userlist.txt' file, which contains hashed passwords. A remote user can obtain the hashed password for the administrator and then supply the hashed password in a cookie to obtain administrative privileges on the target application.

With administrative privileges, the user can edit the 'config.php' file and upload arbitrary files for execution.

A demonstration exploit URL is provided:


The original advisory is available at:

Impact:   A remote user can obtain authentication information.
Solution:   No solution was available at the time of this entry.
Vendor URL: (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.

 Source Message Contents

Date:  Tue, 24 Jan 2006 19:34:38 +0300
Subject:  [eVuln] Text Rider Sensitive Information Disclosure

ew eVuln Advisory:
Text Rider Sensitive Information Disclosure


Software: Text Rider
Sowtware's Web Site:
Versions: 2.4
Critical Level: Dangerous
Type: Sensitive Information Disclosure
Class: Remote
Status: Unpatched
Exploit: Available
Solution: Not Available
Discovered by: Aliaksandr Hartsuyeu (
eVuln ID: EV0046

Directory data isn't protected by htaccess in default installiation.
This can be used to retrieve registered user's information including
logins and password's md5 hashes. 

Cookie-based authentication is threatened. 
To authenticate as administrator cookies need to contain the folowing: 
username=[admin user] 
password=[md5 hash] 

Administrator has an ability to edit "config.php" file and upload
arbitrary files. 

System access is possible.

URL Example: 


No Patch available.

Original Advisory:

Discovered by: Aliaksandr Hartsuyeu (

Go to the Top of This SecurityTracker Archive Page

Home   |    View Topics   |    Search   |    Contact Us

Copyright 2015, LLC