SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Security)  >   F-Secure Anti-Virus Vendors:   F-Secure
F-Secure Anti-Virus Buffer Overflow in Processing ZIP Archives Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1015507
SecurityTracker URL:  http://securitytracker.com/id/1015507
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Jan 19 2006
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): Various versions
Description:   A vulnerability was reported in F-Secure Anti-Virus. A remote user can execute arbitrary code on the target system.

A remote user can create a specially crafted ZIP archive that, when processed by the anti-virus software, will trigger a buffer overflow and execute arbitrary code on the target system.

A remote user can also create specially crafted RAR and ZIP archives that will not be properly scanned by the target system. As a result, a false negative scan may occur.

The following products and versions are affected:

F-Secure Anti-Virus for Workstation version 5.44 and earlier
F-Secure Anti-Virus for Windows Servers version 5.52 and earlier
F-Secure Anti-Virus for Citrix Servers version 5.52
F-Secure Anti-Virus for MIMEsweeper version 5.61 and earlier
F-Secure Anti-Virus Client Security version 6.01 and earlier
F-Secure Anti-Virus for MS Exchange version 6.40 and earlier
F-Secure Anti-Virus for Firewalls version 6.20 and earlier
F-Secure Anti-Virus 2004, 2005 and 2006
F-Secure Anti-Virus for Linux Workstations version 4.52 and earlier
F-Secure Anti-Virus for Linux Servers version 4.64 and earlier
F-Secure Anti-Virus for Linux Gateways version 4.64 and earlier
F-Secure Anti-Virus for Samba Servers version 4.62
F-Secure Anti-Virus Linux Client Security 5.11 and earlier
F-Secure Anti-Virus Linux Server Security 5.11 and earlier

Impact:   A remote user can execute arbitrary code on the target system.

A remote user can obfuscate malicious code so that it will not be detected by the anti-virus system.

Solution:   The vendor has issued a fix. A patch matrix is available in the vendor's advisory at:

http://www.f-secure.com/security/fsc-2006-1.shtml

Vendor URL:  www.f-secure.com/security/fsc-2006-1.shtml (Links to External Site)
Cause:   Input validation error, State error
Underlying OS:   Linux (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Date:  Thu, 19 Jan 2006 08:09:38 -0500
Subject:  F-Secure Security Bulletin FSC-2006-1, Code execution vulnerability in ZIP and RAR-archive handling


http://www.f-secure.com/security/fsc-2006-1.shtml
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC