SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Forum/Board/Portal)  >   Drupal Vendors:   drupal.org
Drupal Access Control Flaws Let Remote Authenticated Users Bypass Security Restrictions on the Target System
SecurityTracker Alert ID:  1039200
SecurityTracker URL:  http://securitytracker.com/id/1039200
CVE Reference:   CVE-2017-6923, CVE-2017-6924, CVE-2017-6925   (Links to External Site)
Date:  Aug 17 2017
Impact:   Disclosure of user information, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 8.x prior to 8.3.7
Description:   Several vulnerabilities were reported in Drupal. A remote authenticated user can bypass security restrictions.

A remote authenticated user can access an Ajax endpoint to bypass access controls on the views subsystem/module [CVE-2017-6923].

A remote authenticated user without privileges to post approved comments can access the REST API to bypass comment approval and post comments [CVE-2017-6924]. Systems with the RESTful Web Services (rest) module and the comment entity REST resource enabled.

A remote authenticated user can bypass entity access controls to view, create, update, or delete entities that do not use or do not have UUIDs or entities that have different access restrictions on different revisions of the same entity [CVE-2017-6925].

Maxim Podorov, Arshad, and Miles Worthington reported these vulnerabilities.

Impact:   A remote authenticated user can bypass security controls on the target system.
Solution:   The vendor has issued a fix (8.3.7).

The vendor advisory is available at:

https://www.drupal.org/SA-CORE-2017-004

Vendor URL:  www.drupal.org/SA-CORE-2017-004 (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2017, SecurityGlobal.net LLC