SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   Apache Subversion Vendors:   Apache Software Foundation, subversion.tigris.org
(Ubuntu Issues Fix) Apache Subversion 'svn+ssh://' URL Processing Flaw Lets Remote Users Execute Arbitrary Commands on the Target System
SecurityTracker Alert ID:  1039149
SecurityTracker URL:  http://securitytracker.com/id/1039149
CVE Reference:   CVE-2017-9800   (Links to External Site)
Date:  Aug 11 2017
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.0.0 - 1.8.18, 1.9.0 - 1.9.6, 1.10.0-alpha3
Description:   A vulnerability was reported in Apache Subversion. A remote user can execute arbitrary commands on the target system.

A remote user (e.g., repository, proxy server) can return a specially crafted 'svn+ssh://' URL to execute arbitrary shell commands on the target user' system. The code will run with the privileges of the target user.

The vulnerability can be triggered during 'checkout', 'export', 'update', and 'switch' commands. The vulnerability can also be triggered when using 'svnsync sync' with one URL argument and the downloaded tree contains 'svn:externals properties;'

Joern Schneeweisz of Recurity Labs reported this vulnerability.

Impact:   A remote user can execute arbitrary shell commands on the target system.
Solution:   Ubuntu has issued a fix.

The Ubuntu advisory is available at:

tps://www.ubuntu.com/usn/usn-3388-1

Vendor URL:  www.ubuntu.com/usn/usn-3388-1 (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Ubuntu)
Underlying OS Comments:  14.04 LTS, 16.04 LTS, 17.04

Message History:   This archive entry is a follow-up to the message listed below.
Aug 10 2017 Apache Subversion 'svn+ssh://' URL Processing Flaw Lets Remote Users Execute Arbitrary Commands on the Target System



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2017, SecurityGlobal.net LLC