SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Security)  >   McAfee ePolicy Orchestrator Vendors:   McAfee
(McAfee Issues Fix for McAfee ePolicy Orchestrator) Apache HTTPD Bugs Let Remote Users Deny Service and Bypass Authentication in Certain Cases
SecurityTracker Alert ID:  1039050
SecurityTracker URL:  http://securitytracker.com/id/1039050
CVE Reference:   CVE-2017-3169, CVE-2017-7668, CVE-2017-7679   (Links to External Site)
Date:  Aug 2 2017
Impact:   Denial of service via network, Not specified
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 5.1.3 and prior, 5.3.2 and prior, 5.9.0 and prior
Description:   Several vulnerabilities were reported in Apache HTTPD. A remote user can cause the target service to crash. A remote user can bypass authentication. McAfee ePolicy Orchestrator is affected.

A remote user can send a specially crafted HTTP/2 request to trigger a null pointer dereference in the mod_http2 component and cause the server process to crash [CVE-2017-7659]. Versions 2.4.24 and 2.4.25 are affected.

A remote user may be able to exploit applications that use the legacy ap_get_basic_auth_pw() function outside of the authentication phase to bypass authentication [CVE-2017-3167].

A remote user can send a specially crafted sequence of request headers to trigger a buffer overread error in ap_find_token() and cause a segmentation fault [CVE-2017-7668]. Versions 2.2.32, 2.4.24, and 2.4.25 are affected.

A buffer overread error may occur in mod_mime when sending a specially crafted Content-Type response header [CVE-2017-7679]. The impact was not specified.

A remote user can send a specially crafted HTTP request to an HTTPS port to trigger a null pointer dereference in mod_ssl via a third party module [CVE-2017-3169]. The impact was not specified.

Vasileios Panopoulos and AdNovum Informatik AG, ChenQin, Hanno Bock, Robert Swiecki, Emmanuel Dreyfus, and Javier Jimenez (javijmor@gmail.com) reported these vulnerabilities.

Impact:   A remote user can cause the target service to crash.

A remote user can bypass authentication on the target system.

A remote user can obtain potentially sensitive information on the target system.

Solution:   McAfee has issued a fix for CVE-2017-3169, CVE-2017-7668, and CVE-2017-7679 for McAfee ePolicy Orchestrator.

5.1.3: Hotfix EPO513HF1202868.zip
5.3.2: Hotfix EPO532HF1202868.zip
5.3.1: Hotfix EPO531HF1202868.zip
5.9.0: Hotfix EPO590HF1202868.zip

The McAfee advisory is available at:

https://kc.mcafee.com/corporate/index?page=content&id=SB10206

Vendor URL:  kc.mcafee.com/corporate/index?page=content&id=SB10206 (Links to External Site)
Cause:   Access control error, Boundary error
Underlying OS:  Windows (Any)

Message History:   This archive entry is a follow-up to the message listed below.
Jun 20 2017 Apache HTTPD Bugs Let Remote Users Deny Service and Bypass Authentication in Certain Cases



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2017, SecurityGlobal.net LLC