SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   Apache Commons Components Vendors:   Apache Software Foundation
Apache Commons Email Component Input Validation Flaw in setSubject() Lets Remote Users Inject SMTP Header Data
SecurityTracker Alert ID:  1039043
SecurityTracker URL:  http://securitytracker.com/id/1039043
CVE Reference:   CVE-2017-9801   (Links to External Site)
Date:  Aug 1 2017
Impact:   Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.0 - 1.4
Description:   A vulnerability was reported in Apache Commons Email. A remote user can inject SMTP header data.

A remote user can supply a specially crafted value containing line break characters to trigger a flaw in the setSubject() method and inject SMTP headers.

Adam Williams reported this vulnerability.

Impact:   A remote user can inject SMTP headers.
Solution:   The vendor has issued a fix (1.5).

The vendor advisory is available at:

http://commons.apache.org/proper/commons-email/security-reports.html

Vendor URL:  commons.apache.org/proper/commons-email/security-reports.html (Links to External Site)
Cause:   Input validation error

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2017, SecurityGlobal.net LLC